Perl crashes when I use SourceTree

Whenever I am using any part of the SourceTree window, OS X perl crash alerts appear every few minutes. When I stop using SourceTree, the crashes stop. Any solution or workaround?

They occur about every 5 to 15 minutes, seem to happen about the time SourceTree refreshes the branch history list. It remains blank for half a second, but reappears ok. SourceTree itself seems to work fine.

I've tried switching bettwen system git and built-in git, no difference. libsvn appears in the backtrace. I have a bookmark to an svn repository, but am currently using it with two git repos (private via ssh, not hubs).

OS X 10.7.3, SourceTree 1.3.2, Xcode 4.2 and 4.3.

crash report: http://pastebin.com/JD3a2RBV

2 answers

1 accepted

Accepted Answer
0 votes

Problem solved here. It looks like authentication failure on my subversion repository was triggering the perl crash. We fixed authentication there (well, we fixed what our ldap server was doing), and the crashes stopped. I had not tried to log into subversion for a while, which is why I didn't know that was the problem.

While subversion auth was failing, it looked like this in SourceTree when doing fetch on the subversion repo:

git -c core.quotepath=false svn fetch

Authentication realm: <https://svn.digitalfish.com:443> Subversion code repository

Password for 'xxxxx':

Authentication realm: <https://svn.digitalfish.com:443> Subversion code repository

Username: Use of uninitialized value $username in chomp at /usr/local/git/libexec/git-core/git-svn line 4048.

error: git-svn died of signal 11

Completed with errors, see above

in command line, trying to use svn just acted like I didn't have the right password.

Thanks for the suggestions!

This appears to be when SourceTree is calling 'git svn fetch' in the background to populate the incoming/outgoing markers. I presume therefore that you have at least one git-svn repository configured in your bookmarks. git-svn uses perl hooks to Subversion, and its these that are crashing.

What version of Subversion are you using?

That's right, I use one remote svn repo and two remote git repos. I used the svn repo for a couple of months before adding the git repos. Interestingly, I did not see the crash until I added the git repos. The crash occurs even if I do not open the svn bookmark.

I removed some old svn authentication files for old servers (in ~/.subversion/auth) and restarted, but perl still crashes.

svn, version 1.6.17 (r1128011) compiled Nov 8 2011, 18:14:46 (the OS X-installed binary)

thanks.

Hmm, my OS X installed version is 1.6.17 too (although built on Feb 1 2012 for some reason). I have lots of git and git-svn repositories in my bookmarks, and I don't see this problem. Indeed, explicitly fetching from a number of git-svn repositories works fine. Do you get the same problem if you open one of your git-svn repositories and use the 'Fetch' toolbar option?

If you have git installed on your command line too, you might want to try changing your Preferences > Git to 'System Git' to see if that makes any difference. There appears to be some clash going on here but I'm just not sure what.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Friday in Europe

Venue Needed! 23rd October

Hey Everyone! Unfortunately, the venue that was hosting us on the 23rd has pulled out so we're looking for a new venue.    If anyone would have a room free that we could use on the ev...

41 views 1 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you