It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JEMH - Disable comments from Mails

I've been trying to setup JEMH to create issues fro emails.

That i have been able to do, but then i, somehow, setup to create comments when an email with the same subject is sent.

On a meeting, it was decided that this is not the behaviour that is wanted because its normal to receive emails with the same subjects, and every mail should be a new issue.

Where can I configure that?

Thanks!

1 answer

1 accepted

0 votes
Answer accepted

Hi Santiago,

In the normal email-reply scenario, commenting behaviour is driven by two things;

1. There is an issue key in the subject (ABC-123). Its reasonable to expect a reply in this instance to comment on the relateed issue.

2. JIRA 5.2.3+ ; Its a reply to an email that has been sent to JIRA already (that created ABC-123). Even without the remote user knowing the issue key, by default JIRA will associate this 'reply' with ABC-123. This solves a problem where otherwise, a new issue would be created.

JEMH doesnt have subject-based matching for commenting purposes as its too error prone, so Im not sure what you have configured.

You say you want 'new' emails to be a new issue, well, they should be, but subject to 1 & 2 above. If you want to disable some of the above its possible with JEMH:

1) Disabling Issue Key recognition:

Set Profile > Email > PreProcessing > Subject IssueKey (comment) Regexps, the value is normally used to match a specific JIRA instance by the email subject [MYJIRA] ABC-123, so, you can set a guaranteed failure to match with 'Never Ever Match 1234567890' so stop subject key matching.

2) Disable reply-to issue location:

Set Profile > Email > PreProcessing > Disable Thread Checking

Thanks Andy, i must have been mistaken then, everytime i tried the profile i started seeing some comments instead of just new issues. I thought the subject of the mail was the reason it was causing it but it seems that answering or forwarding those emails were the events that were triggering comments

I will have to test if its indeed like this, but now that you mentioned i think im pretty sure that was the case

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Align

Best Practices in Jira Align

Hello Jira Align customers! In order to better serve you on your journey with Jira Align, the Community team has worked with the Jira Align team to curate the content in this collection to better s...

102 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you