How to access git respository using tortoisehg


I'm using windows 7 64 bit and of course TortoiseHG 64bit. I created a git repository in bitbucket but I'm not able to access it.

I followed a couple of instructions on the internet about using TortoiseHG to access a git repo. So far it works (at least for unsecured repos) but it always fail when I tried to access my private repository in github over ssh.

I really do hope someone can help me point what I'm missing here or is there special behavior in bitbucket that I need to know?



1 answer

Hi Harold,

It seems as though you need to set-up the private repository to use the SSH protocol, the following guide has some great examples to guide through the complete process:




Thanks for the prompt response.

I actually have other repositories in bitbucket but they're are Mercurial. I have no problems accessing Mercurial repository over SSH as well as the SSH key i've registered. The trouble I'm having right now is accessing a git repository over SSH.

Can you clarify this statement:

but it always fail when I tried to access my private repository in github over ssh

Are you using Bitbucket or GitHub? Also, what does your ~/.ssh/config look like for Bitbucket? What about your git config? Can you paste the psuedo or real output of what those files look like here?


I made some some testing. And it's probably easier to explain in the following manner:

TortoiseGit + GitHub Git Private repo (via ssh) = OK

TortoiseHG + HGGit + GitHub Git Public repo (no ssh) = OK

TortoiseHG + HGGit + GitHub Git Private repo (via ssh) = NOT OK

TortoiseHG + GitHub Mercual Private Repo (via ssh) = OK

It seems that TortoiseHG with the HGGit plug-in doesn't utilise Pageant to authenticate SSH access. I keep getting a message that there's no such repository. However, for plain vanilla TortoiseHG and GitHub Mercurial repo, it works ok via SSH.

Ok, i finally got it!

Just for the record the URL is what I was using for a guide before plus a couple more other forums.

But now it turns out that I'm just missing the "git+" in front of the "ssh://git@bitbucket...". So it must read "git+ssh://", not "ssh://...", not "git://..." and not even "ssh+git://...". This is the part that's not mentioned in the above-mentioned URL.

The "git+" thingy is application or plug-in specific and it's mentioned here:

This is really kind of a relief. I did my first attempt to make this work three months ago and set it aside coz I couldn't figure it out.

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published Tuesday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

465 views 8 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot