Error migrating from Twiki to Confluence

I am trying to migrate from Twiki to Confluence and stuck at one error:

2011-10-24 19:28:12,588 ERROR [http-8080-2] [confluence.rpc.xmlrpc.XmlRpcServer] service javax.servlet.ServletException: org.apache.xmlrpc.ParseFailed: Content is not allowed in prolog.
 -- url: /rpc/xmlrpc | userName: anonymous
javax.servlet.ServletException: org.apache.xmlrpc.ParseFailed: Content is not allowed in prolog.
    at com.atlassian.confluence.rpc.xmlrpc.XmlRpcServer.serviceXmlRpcRequest(XmlRpcServer.java:122)
    at com.atlassian.confluence.rpc.xmlrpc.XmlRpcServer.service(XmlRpcServer.java:86)
    at com.atlassian.confluence.servlet.SpringManagedServlet.service(SpringManagedServlet.java:64)

This error is seen in the confluence logs and it is thrown when the attachments are loaded. To make things worse, the error is thrown at different points every time and there is nothing common between them. Gives me a feeling that the error has nothing to do with a specific attachment. Following is the error in uwc log.

2011-10-24 19:39:32,588 ERROR [Thread-4] - Unexpected problem while converting:
null
java.lang.NullPointerException
        at biz.artemis.confluence.xmlrpcwrapper.AttachmentForXmlRpc.getFileName(
AttachmentForXmlRpc.java:91)
        at biz.artemis.confluence.xmlrpcwrapper.RemoteWikiBroker.storeAttachment
(RemoteWikiBroker.java:548)
        at com.atlassian.uwc.ui.ConverterEngine.sendAttachmentRemoteAPI(Converte
rEngine.java:1443)
        at com.atlassian.uwc.ui.ConverterEngine.sendAttachment(ConverterEngine.j
ava:1383)

Anyone seen this before?

2 answers

1 accepted

Accepted Answer
0 votes

Well moving data can change the encoding silently. So, its possible that if it was a character encoding issue, that the character encoding got magically adjusted during the file system copy. Glad it got worked out.

Well, I can't think of anything better. So marking this as the answer. Thanks.

Some thoughts:

  • Could you be triggering out of memory errors?
  • Which version of Confluence are you migrating to? (The UWC isn't currently ready for Confluence 4.)

Laura,

Thanks for the response. I have in fact looked for out of memory errors. There was none. I still tried with a higher memory (1GB max) but that didn't help either.

Confluence vesion is 3.5.6.

I have no idea what changed, but it started working once I moved everything to my Mac! I have used the same property files.

I am bit confused on how to close this question now because I am not sure why the error went away :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 3 hours ago in Europe

Topic Tuesday: Pizza Toppings

Today we're off to Canary Wharf for our next event at Moody's  Investors Service, so I hope you can all make it. Please RSVP here if you can: https://aug.atlassian.com/events/deta...

11 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you