Error abort: unexpected response: empty string (bitbucket)

I can't push changes to the repo (bitbucket). I am finding difficult to find the cause of the problem with this message:

E:\Umbraco\Railway Children\source>hg --repository "E:\Umbraco\Railway Children\

source" push --force --debug --verbose --time --traceback

pushing to https ://bitbucket.org/BluefinDigital/railway-children

...

bundling: www/xslt/ShopHome[XSLT].xslt 39/41 files (95.12%)

bundling: www/xslt/UpdatePayment[XSLT].xslt 40/41 files (97.56%)

bundling: www/xslt/XSLTsearch.xslt 41/41 files (100.00%)

sending unbundle command

sending 203588 bytes

using auth.bitbucket.org.* for authentication

sending: 64/396 kb (16.16%)

sending: 128/396 kb (32.32%)

sending: 192/396 kb (48.48%)

sending: 198/396 kb (50.00%)

sending: 198/396 kb (50.00%)

http auth: user fabiomilheiro, password ***********

using auth.bitbucket.org.* for authentication

bitbucket.org certificate successfully verified

sending: 262/396 kb (66.16%)

sending: 326/396 kb (82.32%)

sending: 390/396 kb (98.48%)

sending: 397/396 kb (100.25%)

sending: 397/396 kb (100.25%)

Traceback (most recent call last):

File "mercurial\dispatch.pyo", line 88, in _runcatch

File "mercurial\dispatch.pyo", line 740, in _dispatch

File "mercurial\dispatch.pyo", line 514, in runcommand

File "mercurial\dispatch.pyo", line 830, in _runcommand

File "mercurial\dispatch.pyo", line 801, in checkargs

File "mercurial\dispatch.pyo", line 737, in <lambda>

File "mercurial\util.pyo", line 471, in check

File "mercurial\commands.pyo", line 4709, in push

File "mercurial\localrepo.pyo", line 1902, in push

File "mercurial\wireproto.pyo", line 307, in unbundle

File "mercurial\httppeer.pyo", line 203, in _callpush

ResponseError: ('unexpected response:', '')

abort: unexpected response: empty string

time: real 5.79

What does that Response error mean? And why am I getting this?

1 answer

0 vote
Jason Worley Atlassian Team Mar 22, 2013

Greetings,

If this issue still persist, there are many factors at play so its hard to offer a solution based on that output.

A few suggestions:

1. Try pushing with SSH

2. Try running hg verify and if necessary, hg recover to roll back the last change if needed

More troubleshooting can be found here, scroll down to the mercurial section:

https://confluence.atlassian.com/display/BITBUCKET/Troubleshooting+SSH+Issues

If these suggestions and link do not get you back on track, let me know and I will help troubleshoot.


Cheers,
Jason | Atlassian

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Agile

What is ChatOps? A guide to its evolution, adoption, and significance

I am the product of AIM. I can hear that door swinging open and closed in my mind with absolute fidelity. I’d recognize that ding anywhere. At 15, as I typed away into AOL IM, I never imagined that ...

26 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you