Does Atlassian use a CDN? Access is impossibly slow from New Zealand

Hi There,

We signed up yesterday morning (NZT) but none of the links from the signup emails would load until this morning (from two different ISPs) But they load so slowly compared to other sites/services it's almost unusable.

Is Atlassian having issues or is this the speed from our part of the world?

Also, in the past 15mins I've had many password errors to the point where neither the "Atlassian On Demmand" credentials or my.atlassin credentials work on this form to get help:

https://support.atlassian.com/secure/ForgotLoginDetails.jspa

I suspect they might be time out issues - dunno?

Any help or pointers in the right direction would be much appreciated.

Cheers

Ben

3 answers

This widget could not be displayed.

OK - so it seems this has been going on for quite a while now (since question is from 2012). I love BitBucket but it is ABSOLUTELY TERRIBLE when you have teammembers accessing it outside of US. From majority of european countries you get like 1 KB/s connection and for some reason bitbucket.org is blocked in China.

Too bad that is seems this won't be fixed anytime soon...

China has a great firewall that blocks a lot of things. Github was blocked at one stage and then unblocked later. Atlassian will just need to request it to be unblocked, but not likely to happen soon.

@Harry Chan - yeah - I know it's the great firewall problem (and can be solved by simply using proxy in SourceTree). However, I'm bringing it up here so that people know in advance that BitBucket is not usable in most international scenarios. I've already tried contacting support and talking on the issue, but they just closed case on me. Which sucks because we as a community could try to solve this.

For China - we could start some petition or reach out to GitHub and see what they did (considering they also cherish "open" culture maybe they would be willing to help).

And for slow connections from Europe & New Zealand we could help debug network connection. But I guess noone in-house really cares about the issue.

This widget could not be displayed.

Try using ping or a trace route program to figure out where your weak link might be.

This widget could not be displayed.

Sorry mate, I don't know how to do that. All I know is that other international services we use (github, pbwiki etc) load a heck of a lot faster. I guess for whatever reason, we can expect the same speed from Atlassian if we signup for a full account.

Cheers

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

81 views 3 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you