Clone failes with unable to access url: unable to get local issuer certificate

Using Sourcetree 1.4.1.0 under Windows 7.

Clone/New -> Clone/Add/Create Repository

In 'Source path/URL', I enter the url, https://me@bitbucket.org/repo_owner/repo_name

(I cannot grant access to the repository, so even if I gave the actual url, you couldn't access it.)

And after I click in 'Destination path', it goes on to 'Repository Type: Checking source'

At first, I was getting:

git-remote-https.exe - Entry Point Not Found

The procedure curl_multi_timeout could not be found in the dynamic link library libcurl.dll.

And the Clone/Add/Create dialog reported

This is not a valid source path/URL

and the Details dialog was blank, no text at all.

I Replaced an older \Windows\SYSWOW64\libcurl.dll with the more recent one in my Git installation directory. That fixed the missing entry point, but now the problem is

fatal: unable to access 'https://me@bitbucket.org/repo_owner/repo_name':

SSL certificate problem: unable to get local issuer certificate

I made sure Sourcetree is permitted in the Windows firewall rules, although, since I dont know what about it to add, I didn't add it to the list of programs in my router's tables.

Can you help me address this problem?

Thanks

3 answers

1 accepted

Accepted Answer
1 vote

Turned out it was a user name conflict. The name with which I was invited to Bitbucket was not allowed by Bitbucket, since it had a '.' in it. The valid name that I created was not properly associated with the repository to which I was to have access.

Unfortuantely, the details of the actions I took to sort this out are hazy to me; I was at a point of dumbly trying this or that. I suppose I could reproduce the problem and recreate the solution, but I am far happier to let it evaporate into the past. What an exercise in frustration.

That is frusterating, especially since nothing along the way hinted at that.

Hopefully Atlassian will address the issue of invites containing illegal characters.

Yes, and to me, a relative noob, it was entirely opaque.

Hi Harold,

Could you atleast give me some idea about, how it was resolved? The user name conflict that is .

Thanks in advance !

-Jewel

Jewel, I don't remember any more than what I wrote here. I no longer have the user name that either precipitated or contributed to the problem, and I no longer use the account of the company for which I devised that user name.

As to the possible contributing causes, again, the period '.' in my ID caused a problem. Does your name have any character outside of a-Z0-9 ? Make sure the name you were invited with is identical to your user name and that its characters are a-Z or 0-9. This is the best I can do for you, sorry. I don't remember how to fix it once it's busted.

Open the sourcetree terminal and run "ssh bitbucket.org". It should ask you to accept a certificate, and once you've accepted the certificate you should be good to go.

Thanks. Did that, with this result:

$ ssh bitbucket.org

The authenticity of host 'bitbucket.org (131.103.20.168)' can't be established.

RSA key fingerprint is <snip>.

Are you sure you want to continue connecting (yes/no)? yes

Warning: Permanently added 'bitbucket.org,131....' (RSA) to the list of known hosts.

Permission denied (publickey).

Returned to Sourcetree, tried it again and got the same error as before,

fatal: unable to access 'https://me@bitbucket.org/repo_owner/repo_name':

SSL certificate problem: unable to get local issuer certificate

What might be required next? It seems there's a cert in the chain that's problematic. Can it be that I should have to mess around with individual certificates?

Another way to put this is, what does Git require as far as certificates/SSL of a plain, vanilla install?

Turned out to be a name conflict. See above.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 7 hours ago in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

48 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you