• Community
  • Questions
  • Can no longer push/pull to bitbucket.org connection actively refused

Can no longer push/pull to bitbucket.org connection actively refused

I can no longer push or pull to any of my projects.

I am using tortoiseHg and the workbench app. A message comes up saying it is pulling or pushing but I am not offered the dialog to enter my password.

In the .hgcr file there is not a setting for password.

Here is the log messge, ANY help appreciated.

% hg --repository M:\Dev\Eclipse Projects\wbcwidgets\wbcgwtwidgets push https://JimInNH@bitbucket.org/JimInNH/wbcgwtwidgets<br< a="">>pushing to https://JimInNH@bitbucket.org/JimInNH/wbcgwtwidgets<br< a="">>URLError: [Errno 10061] No connection could be made because the target machine actively refused it
[command returned code 255 Fri Jan 03 13:40:29 2014]

3 answers

1 accepted

SOLVED. The problem was there was a proxy settings section in my global settings file. The proxy was for a different repository. Deleted the proxy section and I am now asked for a password.

Moral. If using more than one repository, put the settings in the .hgrc file of each project, not in the global settings.

Not sure how that got there but glad all is working now.

0 vote
Jason Worley Atlassian Team Jan 04, 2014

That error is generally an indication of a port (not being set or set incorrectly) or a proxy issue. Have there been any recent changes to your environment? Are you able to push/pull to any other repos? Can you try it from another computer or over SSH?

I can log in from another machine. I compared hgrc files on the two machines and can find no difference. On the machine I can log on with, I am asked for my password. I the machine I really care about, it does NOT ask for password.

If I can change settings so I am asked for the password I think all would be OK but I can not see how to fix that.

---- Added 1/13/2014 -------

Still having problems.

To answer a previous question, I can log in and push/pull from my work computer. When doing so using the TortoiseHg Workbench I am asked from my password.

On my main computer, which can not pull from bitbucket, I can get stuff out of a 'local' repository and it asks from username and password.

I am not successful in DOS or using the workbench.

I can edit the project and global settings files and there is nothing stored about password.

SO, what else could cause the pull process never to ask for a password.

I uninstalled my 1 year old TortoiseHg and installed the current version but it made no difference.

I am really hoping someone could shed some light on this....... How to force asking for the password or finding where a password is stored that is being used in place of asking my. Perhaps that is the password for another account.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

101 views 2 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot