Bamboo is trying to use the wrong branch when sharing artifacts between plans

If I have 2 repositories with the same branch name, and the second repository is dependent on the first, when I use the artifact download task, how can I make sure the artifacts that are used come from the branch that shares the same name as the first repository.

Currently in the build log the artifact download task says it is trying to use the artifacts from the default branch and not the branch I am working off of.

2 answers

1 accepted

Hi Jay,

I'm not sure if this is the same issue, but could it be that you're affected by https://jira.atlassian.com/browse/BAM-13584 ? If so, I'd urge you to vote on that issue (and add yourself to it as a watcher).

regards,

Yes, that looks like the problem I am having.

I've been looking into this issue as well and even though it seems this issue was fixed in 5.1.1 (as per BAM-13584) , still in 5.3 I cannot chose a branch to pick up my shared Artifacts from in the Artifact downloader. Just wondered if this is still a issue or am I missing something?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Canada

Happy New Year - First AUG of the year - great success

Hi Everyone, Hope everyone had a great holiday season and is ready for an exciting 2019.  We had our first AUG last night featuring Tempo Timesheets.  A great presentation and lots of int...

17 views 0 1
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you