Bamboo home directory not being accepted

I just installed bamboo.

Entered the following for the bamboo home specification in: bamboo-init.properties

bamboo.home=/home/devwp/public_html/bamboo-home

Restarted bamboo: bin/start-bamboo.sh

However, Bamboo still complains with the following:

Bamboo home directory specified: .
There was an error creating the Bamboo Home directory. The most common cause is you haven't specified it.
To fix this, simply set the bamboo.home property in the file /atlassian-bamboo/WEB-INF/classes/bamboo-init.properties to your chosen bamboo home directory .

1 answer

0 votes
Ian Buchanan Atlassian Team Aug 30, 2017

It sounds like a permissions problem. If you aren't running as `devwp` then Bamboo can't properly read/write/create files in it's home.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 12 hours ago in United States

Administrators Cleanup

Good morning, After a long weekend cleaning up, I am still in the cleanup mode 😊. I am curious to know: When do you feel the urgency to cleanup your Atlassian Tools? How many times do y...

16 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you