After changing my password, I cannot push to my repo without being required to solve a CAPTCHA

Hi Bitbucket team,

I had to change my password at work as per the password policy. Since that time, virtually every time I try to push to a repo hosted on my company's Bitbucket server, I receive this error:

Your Bitbucket account has been locked. To unlock it and log in again you must
solve a CAPTCHA. This is typically caused by too many attempts to login with an
incorrect password. The account lock prevents your SCM client from accessing
Bitbucket and its mirrors until it is solved, even if you enter your password
correctly.

If you are currently logged in to Bitbucket via a browser you may need to
logout and then log back in in order to solve the CAPTCHA.

I then have to log into Bitbucket and solve the CAPTCHA. I can push again within a minute on the same repo and not have to enter the CAPTCHA. If I wait longer than a minute, or if I immediately switch to a different repo and push, I will have to solve the CAPTCHA again.

I can however go to the Bitbucket web page, and repeatedly log out and log in without having to solve any CAPTCHA. Its always happens after attempting to push to a repo.

I've already made sure to change my git's password with

git config --global credential.helper wincred
And I can confirm that it is using the correct password with
git credential fill
protocol=https
host=gitscm.mycompany.com

So I don't understand what could be causing this.

I have seen that other people have complained about this issue.

https://answers.atlassian.com/questions/274173

https://answers.atlassian.com/questions/259633

Any ideas on how to fix this?

Best regards,

Matthew

 

2 answers

This widget could not be displayed.

Hi Matthew,

Could it be that you have either a script or a build job that is using your old credentials? One thing you could do is have a look (or ask your admin to have a look) at Bitbucket's audit logs to see which IP is triggering the authentication failures for your user. You can find them in BITBUCKET_HOME/log/audit/.

An authentication failure would be logged as follows:

0:0:0:0:0:0:0:1 | AuthenticationFailureEvent | admin | 1474293778897 | admin | {"authentication-method":"basic","error":"Invalid username or password."} | @10IA6L8x962x13x0 | -
0:0:0:0:0:0:0:1 | AuthenticationFailureEvent | admin | 1474293800985 | admin | {"authentication-method":"basic","error":"Invalid username or password."} | @10IA6L8x963x18x0 | -
0:0:0:0:0:0:0:1 | AuthenticationFailureEvent | admin | 1474293802155 | admin | {"authentication-method":"basic","error":"Invalid username or password."} | @10IA6L8x963x22x0 | -
0:0:0:0:0:0:0:1 | AuthenticationFailureEvent | admin | 1474293819180 | admin | {"authentication-method":"basic","error":"Invalid username or password."} | @10IA6L8x963x26x0 | -

This is from testing from localhost (hence 0:0:0:0:0:0:0:1) with the user 'admin'.

 

Hi Michael.

I created two test git repos today, that only I have access to and which I haven't applied and build jobs to, and I still get this message. I believe it must either have something to do with my git configuration that I cannot figure out, or something on bitbucket. I have sent the admins an email with your instructions.

Would you have any guesses on the root cause if we can safely rule out scripts/build jobs and etc. pushing or pulling to these test repos?

Thanks and best regards,

Matthew Moisen

This widget could not be displayed.

This just happened to me today, did you manage to find a solution?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

129 views 16 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you