After Bamboo 4.2 upgrade script tasks won't excecute properly

I upgraded from 4.0 to 4.2 and now I have script tasks that will not run.

I give it the file name, a Windows batch script (.bat) and the directory it's located in.

Bamboo spits back errors:

"Unable to find exectuable at genproj.bat"
"Access is denied"
"Access is denied"
"Access is denied"

The script runs through additional subfolders setting up some structures so it looks like it actually is running the script but why is the task failing?

My bamboo agent on the build agent has not changed from when it worked with 4.0

Linux Bamboo build server, WindowsXP build agent

4 answers

1 accepted

We have verified this as a bug in The workaround at the moment is to specify the full path where the batch file is placed

0 vote

Can you attach a sceenshot of your task configuration? Also, does the agent run as a service?

My image isn't uploading for some reason

But the configuration is like this

Task Description: Generate Project Files

Script Location: File

Script File: genproj.bat

Agrument: blank

Environment Variables: blank

Working Sub Directory: location_of_script (only 1 level down from the top level directory)

The agent is running as a service

What if you change it to:

Script File: location_of_script/genproj.bat

Working Sub Directory: location_of_script (or whatever you need)


It is running as a service.


I am also having the same problem since upgrading Bamboo to 4.2.

I have a similar set-up to the one above where I use the Script Task to run a batch file. I am now getting an error saying that the file is no longer recognised as a batch file, thus causing the build to break.

Here is the error in the logs:

simple Starting task 'Moving files to folder' of type 'com.atlassian.bamboo.plugins.scripttask:task.builder.script'

error Unable to find executable at Move_files.bat

command Beginning to execute external process for build 'Franchisee Profile - Move files'\n ...running command line: \nMove_files.bat\n ... in: E:\bamboo-home\xml-data\build-dir\FP-TRANSFER\n

error 'Move_files.bat' is not recognized as an internal or external command, operable program or batch file.

I tried your suggestion above to fill in the full path to the batch file, but as this folder name will change each time a build will run, this is not an option.

Is this a known issue in 4.2 or should I open a ticket for it?



0 vote
Eddie Webb Community Champion Aug 20, 2012

Did you update the remote agent to be the 4.2 jar, is ist running under the same user? Can you manually execute that script as the user that runs the bamboo remtoe agent?

0 vote

Eddie, you don't need to update agent jars.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted 4 hours ago in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

21 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot