need to change the port for accessing synchrony

This question is in reference to Atlassian Documentation: Administering Collaborative Editing

Hello all,

if we use the default config for synchrony, the internal proxy has problems to access the localhost because confluence is running in a docker and internal proxy should prefer confluence:8091/... for localhost:8091 to access the synchrony. If we proxy the requests to synchrony via nginx and disable the internal confluence proxy, such config works as expected with the one exception: confluence generates synchrony urls with port :8091 and this port should be opened extra on a host machine. The responses from :8091/synchrony and :80/synchrony are now the same and both work well, but the web pages want to go to :8091.

We would like either to say the confluence to access  synchrony via internal proxy under the specific hostname (eg. confluence:8091) or to say what port should be used to access the synchrony, if the internal proxy is disabled (in our case 80).

We use confluence 6.0.1 in Docker + Oracle JDK 8

Any hints would be appreciated!

Kind regard,

Gena

 

3 answers

This widget could not be displayed.

Synchrony's port can be specified with -Dreza.port (not -Dsynchrony.port - see https://jira.atlassian.com/browse/CONF-45565).

I'm not sure I follow re. confluence:8091. Synchrony binds to :8091 on all interfaces by default. Confluence (6.0.2 anyway) hardcodes 'localhost' in its 'Synchrony Internal Service URL' - see https://jira.atlassian.com/browse/CONF-45567

This widget could not be displayed.

We are on 6.0.3 in a docker now. The synchrony proxy is enabled. Following nginx configuration works (important is the location /synchrony-proxy):

location /synchrony-proxy {
        proxy_set_header X-Forwarded-Host $host;
        proxy_set_header X-Forwarded-Server $host;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass http://confluence:8091/synchrony;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "Upgrade";
    }
 
 
 
 location / {
                proxy_set_header Host $http_host;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_redirect off;
                proxy_pass http://confluence-backend;
        }
 
}
This widget could not be displayed.

Port is configurable by adding the following line (say your preferred port is 9004) to /bin/setenv.sh

CATALINA_OPTS="-Dsynchrony.port=9004 ${CATALINA_OPTS}"

Cheers,

Zlatko 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

139 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you