Unable to install Confluence Questions

When trying to install Questions the installation fails. We are running 5.7.1.

 

I upgraded the Universal Plugin Manager but after failing the Questions installation the log states:

 

2015-08-14 07:29:18,272 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements OBR resolver has 2 unsatisfied requirements for installing plugin_202852181223565927_confluence-questions-1.0.448.obr

-- url: /rest/plugins/1.0/ | referer: https://confluence.XXX.ca/plugins/servlet/upm/manage/all | userName: willrya

2015-08-14 07:29:18,287 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=com.atlassian.renderer)(version>=6.2.10)(version<=6.2.10))

-- url: /rest/plugins/1.0/ | referer: https://confluence.XXX.ca/plugins/servlet/upm/manage/all | userName: willrya

2015-08-14 07:29:18,287 ERROR [UpmAsynchronousTaskManager:thread-3] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&(package=com.atlassian.fugue)(version>=1.1.0)(!(version>=2.0.0)))

-- url: /rest/plugins/1.0/ | referer: https://confluence.XXX.ca/plugins/servlet/upm/manage/all | userName: willrya

2015-08-14 07:29:18,584 WARN [UpmAsynchronousTaskManager:thread-3] [upm.core.install.DefaultPluginInstallationService] execute Plugin installation failed: Failed to resolve plugin dependencies within OBR [plugin_202852181223565927_confluence-questions-1.0.448.obr]. Please see the logs for more detailed information.

6 answers

Hi Ryan,

It seems that it's failing to install the plugin because it needs another library that seems to be not updated. Would you mind updating all your plugins then try to install questions?

Cheers,
WZ

Hi William,

Thanks for your quick response. I am happy to update other plugins but the problem for me is that this instance runs on an isolated network (i.e., no Internet connection). As such, it would be a long process to do them one by one. Is there a way to further isolate the problem plugin(s)?

 

Ryan

0 vote

Hi Ryan, you could downgrade your Question's plugin for the one that was working.

Hi, I can't help but comment here that downgrading the plugin to a previous version isn't exactly a solution. I am running Confluence server 5.7.3 and I see the same errors while trying to install Confluence Questions. Would somebody be able to help me identify what exact plugins are being referred to here and how can we upgrade them?

Thanks in advance!

Somujit

I am currently running an evaluation of Confluence and thought I'd also download and try Questions. I have a week left, and thought I'd see what it does.

But I can't install it - an error always appears and tells me to check logs :

An error occurred during installation. Refer to the logs for more information.

As above, looking at the logs, it seems to be a dependency issue

2015-10-25 16:40:00,439 ERROR [UpmAsynchronousTaskManager:thread-2] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements OBR resolver has 2 unsatisfied requirements for installing plugin_6953136590530549209_confluence-questions-1.0.448.obr
 -- url: /rest/plugins/1.0/ | referer: http://udiana:8090/plugins/servlet/upm | userName: admin
2015-10-25 16:40:00,441 ERROR [UpmAsynchronousTaskManager:thread-2] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&amp;(package=com.atlassian.renderer)(version&gt;=6.2.10)(version&lt;=6.2.10))
 -- url: /rest/plugins/1.0/ | referer: http://udiana:8090/plugins/servlet/upm | userName: admin
2015-10-25 16:40:00,441 ERROR [UpmAsynchronousTaskManager:thread-2] [upm.core.install.ObrPluginInstallHandler] logUnsatisfiedRequirements Unsatisfied requirement: (&amp;(package=com.atlassian.fugue)(version&gt;=1.1.0)(!(version&gt;=2.0.0)))
 -- url: /rest/plugins/1.0/ | referer: http://udiana:8090/plugins/servlet/upm | userName: admin
2015-10-25 16:40:00,502 WARN [UpmAsynchronousTaskManager:thread-2] [upm.core.install.DefaultPluginInstallationService] execute Plugin installation failed: Failed to resolve plugin dependencies within OBR [plugin_6953136590530549209_confluence-questions-1.0.448.obr]. Please see the logs for more detailed information.
 -- url: /rest/plugins/1.0/ | referer: http://udiana:8090/plugins/servlet/upm | userName: admin

 

I am using :

Confluence installer 5.8.15

Ubuntu Linux 14.04 LTS

I have made sure all the (default) plugins are updated, including UPM.

Thanks, Alastair

Just ran into the same error - took me a few minutes, then realized I was trying to install Confluence Questions through the JIRA Admin panel, and not the Confluence Admin panel. Once I switched over to the Confluence Admin panel, it worked perfect.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

73 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you