Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,779
Community Members
 
Community Events
168
Community Groups

Topics in Questions are gone

I have a problem with the Topics in Confluence Questions. For some reason are most of my topics in the list TOPICS gone. At the moment i have in the pool approximately 100 Questions with maybe 60 topics. I was used to look for questions that have already been ask in the way that i have clicked on the tab TOPICS and there was a list of all the topics in the system. Now when i click on the TOPICS tab the list has only 11 topic listed. Do you have any iidea where are the other gone?

2 answers

Hi, rebuilding the index helped in our case, maybe you can try it.

0 votes

Hi Jan, how did you solve the problem? 

I've got the same problem here - no topics available on Topics overview and when asking a question - but you can see the topics that were used for existing questions. 

Hi

in the end I did not have to deal with it. I have found out that when you ask a new question using a topic that already exist (that is however not visible) it comes somehow back.  I got lucky that my users managed to ask so many questions, that soon most of the Topics were back from alone. So you have two possibilities, either you wait until the users through asking questions bring the topics back or you'll try to rebulid the index what has Daniel suggested That would be of course the better option. Next time I will not be waiting and after an update of Confluence Questions I will definitely try to rebulid the index. Eventhough I have no idea how difficult that would be.

Hier is what i have found to this problem

https://confluence.atlassian.com/confkb/how-to-rebuild-the-content-indexes-from-scratch-on-confluence-server-110035351.html

But I think Daniel, or someone that has such a content reindexing performed, could verfy that procedure.

I am sorry that i did not help you much but maybe there is someone with experience that could us tell more.

Hi Jan,

thanks for your fast answer - i could reproduce the 'comeback' of existing topics by using them in a new question, but I think that won't work on livesystem :(

Thanks also for the index restore solution - think I'm gonna try this. @dvehof Any tips regarding this?

I will post solution when I found one ;)

The link above for rebuilding index from scratch is the way to go, but I would suggest to try just rebuilding the index in the GUI first (no need to stop confluence when this would be a problem for you). 

So berfore stopping and deleting the old index I would just try step 6 to see if this helps:

Navigate to Confluence Admin > Content Indexing and click "Rebuild"

@Daniel Vehof wohoo - thanks worked perfect for me. No need to stop system - just started with step 6 as you mentioned.

Navigate to Confluence Admin > Content Indexing and click "Rebuild"

All topics came back!

THANK YOU so much! Will have a look on livesystem tomorrow after update.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Online AMA this week: Your project management questions answered by Jira Design Lead James Rotanson

We know that great teams require amazing project management chops. It's no surprise that great teams who use Jira have strong project managers, effective workflows, and secrets that bring planning ...

166 views 1 6
Read article

Atlassian Community Events