Is there a bug on the popular questions macro?

I've added the 'popular Questions' macro to many of my Confluence pages, with the 'Ask a Question' button included. I have also set topic tags to filter for the macro (i.e. so that it only shows Questions with these topic tags).

It looks like there is a bug with this macro, because the 'ask a question' button does not appear until a question is asked with one of the filtered topic tags. This makes for a poor user experience as people can't ask Questions directly from these Confluence pages until there is at least one question with one of the topic tags designated for that macro. This doesn't seem to make sense and I'm thinking this is a bug with the macro.

Can someone please look into this issue and let me know if/when it should be resolved?

1 answer

0 votes
Ann Worley Atlassian Team May 05, 2017

I reproduced the case you describe to the best of my understanding. I filtered on a topic with no questions but the "Ask a question" button did appear.Screen Shot 2017-05-05 at 9.16.52 AM.pngPlease let me know what version of Questions and what version of Confluence you are using.

Thanks Ann! The version of Confluence I am using is Confluence 1000.1138.0 . I'm assuming the version of my Questions space would be the same, but if not, please let me know. This bug is still persisting for me across numerous Confluence pages.

 

Popular Questions 'Ask a Question' Button Bug.png

Hey Ann, I was hoping to get a follow-up on the above. I am also seeing another bug when using the 'Popular Questions' macro. When I ask a Question from the main 'Questions' space, it will give me recommended topic tags to use when adding them to my Question.

However, when asking a Question using the 'Ask a Button' feature on a Confluence page, it does not give any recommended topic tags while I am entering them in. This allows users to enter multiple variations of the same topic whereas the recommendations provided using the main Questions space solve for this problem.

Is this a known bug for the 'Ask a Question' button, and does Atlassian have any plans to solve for this?

Ann Worley Atlassian Team Jun 06, 2017

From the version you are reporting I can see that you are using our Confluence Cloud offering. I wanted to test the behavior you are describing but Questions is temporarily unavailable for my Cloud test instance. The best course of action now is to open a support request so the Cloud support team can check whether the issues are happening on all Cloud instances or if not, if there is a way they can fix yours.

Hi Ann, we actually recently migrated to having Atlassian hosted on a server. Should I still open a support request?

Ann Worley Atlassian Team Jun 06, 2017

That is interesting because the current Server version is 6.2.1 - the version you are reporting has never been a server version (1000.1138.0). Please do open a ticket so Support can examine your logs.

Hi Ann, sorry again for the confusion. We are on Confluence 6.0.6. Hopefully this helps.

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

498 views 1 15
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot