Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't save after editing a question

Hey everybody,

when i'm trying to save a questions after editing it (the question contain pictures), i will get the error:  "Error found in the content of the question" and "Error saving draft". Even though the first time saving the question after creating it works without any errors.

If I remove all pictures I can save without any problems.

 

 

 

2 answers

0 votes
Zak Laughton Atlassian Team Mar 08, 2019

Hi Malte,

Interesting that this issue only happens in the Questions app, and it only affects the question field.

Since the scope of the issue is so specific, this is likely due to some sort of data corruption in the Questions app. In your logs, there are several "cannot use file"-type errors that point to a data issue, but the one that stands out to me is the line that includes this bit:

Unable to resolve the resource identifier IdAndTypeResourceIdentifier

It looks like you may be affected by the issue addressed in this knowledge base article: Unable to process request due to broken reference.

Fortunately, there are some things you can do to rebuild the data in cases like these. Here is what I would try:

  1. Take the steps described in the Resolution section of Unable to process request due to broken reference (rebuild the index in the application, rebuild the index from scratch)
  2. If the issue persists, try the steps on How to clear Confluence plugins cache.

NOTE: The "reindex from scratch" and "clear plugins cache" steps will both require restarts.

Let us know how it goes!
– Zak

Hi Zak,

sadly I wasn't able to resolve the problem. But I noticed the error only occurs when the questions was asked in a space. If the question isn't part of a space, I'm able to edit and save the question. If nothing is attached to the question the error doesn't occur, even when the question was asked in a space.

I also noticed, I've got a large number of empty drafts. I'm not able to delete a draft or to continue one. If I try to continue any draft, I'll get a "Page not found".

-Malte

Con-Drafts.PNG

0 votes
Zak Laughton Atlassian Team Mar 07, 2019

Hi Malte!

Since this only happens when pictures are included, it sounds like there might be an issue with Confluence saving files. Unfortunately, it's difficult to know without a bit more information.

  • Do you receive an error when you try to attach files to a Confluence page?
  • Do you see any errors show up when this happens in <confluence-home>/logs/atlassian-confluence.log?
  • Do you see any errors show up in the Network or Console tabs of the browser developer tools when triggering this error?

– Zak

Hi Zak,

I don't get any errors while attaching a file. But I found multiple errors in the log file.

The error only occurs when editing a questions, when editing an anwser everything works fine.

Errors

-Malte

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

🍻🍂Apptoberfest Update: Upcoming Virtual Events 🎉

Hello Community! I hope you've been enjoying the 🍂Apptoberfestivities🍂 (I know I have!) The event is heating up next week with a series of virtual events that we're calling the 🍻🍂Partner App ...

65 views 0 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you