Running Confluence 6.14.0, in a virtuel ubuntu server on QNAP NAS.
Database is postsgresql. Running locally in the same the virtuel ubuntu server
This has worked flawless for years.
I bought a new NAS.
I restored the virtuel server on the new NAS.
Postgresql and confluence starts fine, and I get presented with the login page.
When trying to login, I just get redirected to the login page again, no error presented.
This only happens when I enter valid user/password.
If I try to login using valid user and wrong password, I get the error message "Sorry, your username and/or password are incorrect. Please try again."
This is true for admin and nomal users.
Also tried the setting up the recovery_admin user with no success.
https://confluence.atlassian.com/doc/restore-passwords-to-recover-admin-user-rights-158390.html
/var/atlassian/application-data/confluence/logs/atlassian-confluence.log
2019-10-27 12:43:32,694 WARN [http-nio-8090-exec-1] [atlassian.seraph.auth.DefaultAuthenticator] login login : 'jonny' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
-- referer: http://172.16.16.215:8090/confluence/login.action?os_destination=/index.action&permissionViolation=true | url: /confluence/dologin.action | traceId: b456af04e41eb56e
2019-10-27 12:43:33,825 WARN [http-nio-8090-exec-4] [common.security.jersey.XsrfResourceFilter] passesAdditionalBrowserChecks Additional XSRF checks failed for request: https://valhal.io/confluence/rest/analytics/1.0/publish/bulk , origin: http://172.16.16.215:8090 , referrer: http://172.16.16.215:8090/confluence/dologin.action , credentials in request: true , allowed via CORS: false
-- referer: http://172.16.16.215:8090/confluence/dologin.action | url: /confluence/rest/analytics/1.0/publish/bulk | traceId: 8f5d128f000bc644 | userName: anonymous
(END)
Sound like something like this, but as I am not able to login to web console.
I only have the shell and postgresql as tools.
https://confluence.atlassian.com/jirakb/user-unable-to-login-with-you-do-not-have-permission-error-596770904.html