Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

calling JIRA REST API from POSTMAN

I am calling the JIRA REST API as below from POSTMAN DESKTOP with authorization Type as BasicAuth or NoAuth and its throwing error as "Issue does not exist or you do not have permission to see it." and "Unauthorized".

https://<domain-name>.atlassian.net/rest/api/3/issue/RPC-260

Can anyone guide me on how to proceed on this.

14 answers

You should be using:

  • Type = Basic Auth
  • Username = <your login username>
  • Password = <your api token>Postman.PNG

This worked, thanks.

Thanks you !!!!

This also worked for me.

Is it just me? Or is this totally bananas? I've been chasing my tail for hours trying to get it to work with OAuth v2.

Is this a normal way to use such a token?

Thanks a lot for this help!

Like agrant likes this

Thanks worked for me as well.

Thanks alot

Thanks!

Just in case somebody else stumbled about this:

Indeed you have to use the API key and not the encoded one (https://blog.developer.atlassian.com/creating-a-jira-cloud-issue-in-a-single-rest-call)

So in Postman you need the API-key; in python (using requests) you need the encoded API

Thank you so much works for me as well.

Like felix_weber likes this
Barb GM I'm New Here Jun 22, 2021

Nice, thanks

Basic authentication with passwords is deprecated

Like Abdulkader Khateeb likes this

I use OAuth2.0 in authentication and all requests tot eh JIRA API have response of UNAUTHORIZED

Hello guys, 

With the basic auth, are you using the API token in the password field? That is how it suppose to work.

Cheers!

Alexandre C.  

How to know the API token?

I had the same situation for a while and finally learned that my username needed to be the email address NOT just the username alone. Though, when I am using Jira I sign in with without the email address. 

As recommended, e-mail as username, API token as password and Authorization type as 'Basic Auth' worked from Postman.

Hello,

I am facing the same problem. Has this issue been resolved ?  any suggestion?

I't works with the browser but i keep having 401Unauthorized with postman

I'm using the e-mail as username and the generated token fro jira as a password

You have to use the username of the application. In my case, I got 401 when using my e-mail and trying to call Jira Insight API.
I clicked the icon in the top right and then Profile, and here I could see that my username was not my e-mail, but a network ID issued by my organization. Using this username I was able to call the API successfully as described above.

Also, different Jira applications does not share the token, so a token created in Jira does not work for Jira Insight.

0 votes
Barb GM I'm New Here Aug 19, 2021

Your token maybe expired.

Go to your Jira instance - personal access token and revoke/delete current token, then recreate your token again, copy and paste to a text file exactly as shown.

In Postman access Authorization - basic auth, and under password copy and paste your new token from above. (hint: Click on show your password to make sure it's copied exactly without any additional spaces at the end), then execute your api. 

hi there ! i set up all headers,authorization, basic auth, api token , user name but getting 404 error please help to resolve it ..

 

jira.JPG

Hi, Can anyone share PostMan Collection for JIRA APIs, it would be very helpful for me to understand it easily?

You can ordinarily import the wadl into Postman, but I haven't had luck lately.

 

https://docs.atlassian.com/software/jira/docs/api/REST/7.6.1/jira-rest-plugin.wadl

Hi All,

 

I am using basic auth with token and still i am getting 

{    "errorMessages": [        "Issue does not exist or you do not have permission to see it."    ],    "errors": {}}

However when i use the same url in browser, with session of jira logged in another tab, i am getting back issue details

Any suggestion?

Hi Sharath,

 

I am having the same issue.

Is your issue resolved ?

Getting issue in Postman "Basic auth with password is not allowed on this instance"

I am using Basic Auth. Email in Username an Token in Password.

Can anyone please help as it was working fine earlier?

1)  click on my picture > bottom left

2) select profile

3) click 'manage your account'

4) click 'security

5) click 'create and manage API tokens'

I love how Pvs_Krishna just responds with the steps to get the token when people are actually asking why that's not working.

Like # people like this

Also running into: "Basic auth with password is not allowed on this instance"

 

So what other options than basic auth does the jira api support?

any updates on how to resolve this?

I'm having same issue, Please suggest..

0 votes
edwin Community Leader May 02, 2019

Hi @Sai Shyam Pasupuleti ,

Please confirm that you have access to the project by viewing the issue on the browser.

https://<domain-name>.atlassian.net/browse/RPC-260

Hi Edwin,

Yes I do have access and I am able to get the data using Chrome REST Service client where as with Desktop version of POSTMAN its failing.

Your response will be highly appreciated

When used Authorization Type - No Auth it says "Issue does not exist or you do not have permission to see it." and below is the screenshot

 

When Authorization Type - Basic Auth it says Unauthorized Find the screenshotSS1.PNGSS2.PNG

Please advice on this.

 

Your timely help is much appreciated

Like Sasikumar Ravi likes this

I am having the same problem. Has this issue been resolved yet.

Thanks,

Mamata

1) I click on my picture > bottom left

2) select profile

3) click 'manage your account'

4) click 'security

5) click 'create and manage API tokens'

Like Allan Maxwell likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you