Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,361,468
Community Members
 
Community Events
168
Community Groups

How to configure SSL by proxying Jira Service Desk application on Apache 2.4 server to run on https

Hi All,

I am using jira service desk 3.16 and wants to run on http and https, for that in server.xml we mentioned 2 connector port entries like below

<!-- Relaxing chars because of JRASERVER-67974 -->
<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
acceptCount="100" disableUploadTimeout="true" bindOnInit="false" scheme="https" proxyName="xxxx.xx.co.in" proxyPort="443"/>

<Connector port="8889" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
acceptCount="100" disableUploadTimeout="true" bindOnInit="false"/>

And from network side, we have created LB and activated SSL certificate key on the on that LB and inside that LB we have mapped the Apache server. After that on Apache server we have created Virtual host and reverse proxy like below

##############For Jira#####################################  

<VirtualHost *:80>
    ServerName xxxx.xx.co.in
RewriteEngine On
RewriteCond %{REQUEST_URI} ^/*
RewriteRule .* http://xxxx.xx.xx.xx:8889/ [P,L]
</VirtualHost>
 

###########################  
ProxyPass / http://xxxx.xx.xx.xx:8889/
ProxyPassReverse / http://xxxx.xx.xx.xx:8889/   #######################

But still it is not working and giving error like below:

Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure stylesheet '<URL>'. This request has been blocked; the content must be served over HTTPS.
20Refused to execute script from '<URL>' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
VM8 Dashboard.jspa:1 Refused to execute script from 'https:/xxxx.xx.co.in/s/10fbafb97f37bd1a002b628e38adb091-CDN/t38b72/713000/802b10c2ff11c51df1201961a4b718d8/437e3a802221a5e0e78effaf664704e2/_/download/contextbatch/js/_super/batch.js?locale=en-US&spectrum=true' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
VM8 Dashboard.jspa:1 Refused to execute script from '

Please help me with SSL implementation and let me know if any workaround is there.

 

2 answers

1 accepted

0 votes
Answer accepted

Hi All,

I have made some chnages in virtual host configuration of Apache like below

<VirtualHost *:80>
    ServerName https://xxxx.xx.co.in:443
RewriteEngine On
RewriteCond %{REQUEST_URI} ^/*
ProxyPass / http://jxxx.xx.xx:8080/
ProxyPassReverse / http://xxx.xx.xx:8080/   </VirtualHost>

During proxy pass, we were passing wrong port that is 8889 and after i made changes with 8080 port it start working on https.

বিগো লাইভের এডমিন সিংগার জোসি আমার কাছে টাকা চেয়েছিলো আমি দিতে পারি নাই করুনার জন্য তাই সে মিথ্যা কথা বলে আমার আইডি বেনড করে দিছে। আমি অনেক খোলার কথা বলছি কিন্তু সে আইডি খুলবে না বলছে। এখন আমি আপনাদের সাহায্য চাই

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events