Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Log in issue Zephyr Test Case Importer (Authentication error)

Hi,

Is there a way I can reset password of Zephyr Test Case Importer utility? I am using cloud version and I had uploaded many test cases in past with Username, Password, Access Key and Secret key. However I do not recall my password and would like to know if there is a way to reset it. I tried resetting Jira password but that does not help.

This is the error - Unexpected Response Code 401.

logs

2019-07-30 10:20:56,704 WARN [AWT-EventQueue-0] ConfiguredHttpClient.handleResponse(1097) | Authentication error: Unable to respond to any of these challenges: {oauth=WWW-Authenticate: OAuth realm="https%3A%2F%2Fhbcdigital.atlassian.net"}

1 answer

1 accepted

0 votes
Answer accepted
Andy Heinzer Atlassian Team Jul 31, 2019

Hi Paresh,

I see that you are trying to use the zephyr importer to add some data into a Jira Cloud site, but are seeing an HTTP 401 error upon trying to do so.

I'm no expert on the function of this utility, but from reviewing the documentation on it in https://bitbucket.org/zfjdeveloper/zfj-importer/wiki/Home, I suspect that this utility is still trying to use the basic auth method with a password for your Jira Cloud site.  If that is the case, then you should be aware that Atlassian Cloud products recently deprecrated the ability to use password in basic auth for REST API.  More details in Deprecation notice - Basic authentication with passwords and cookie-based authentication.

There are other ways to make basic auth calls to Jira Cloud, but they require the use of an API Token, and that token has to be used in creating a specific base64 string explained in Basic auth for REST APIs.

It looks like this utility will need an update to the code to be able to connect to Jira Cloud today.  However I am uncertain where exactly to direct a request to update that specific repo.  Perhaps reaching out to Zephyr support directly in https://support.smartbear.com/message/?prod=zephyr might be able to provide you with some more details about that utility that could help here further.

Regards,

Andy

Thank you Andy for the your time and details. It really helped. I am reaching to Zephyr support for further updates. 

Hi Paresh, did you get any update about this authentication error from Zephyr support?

Hello @Paresh Joshi  Did you found solution for this ? 

Hi,

I had a similar issue as I had to create an API token and use that as the password. I also had to update to the newest version of Java.

After doing all that it finally worked.

I also reached out to Zephyr support and they couldn't find anything. I then decided to see if it was the java version being out of date and it was. This happened around the same time as you experienced the problem.

Tony.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

5 mobile apps for Jira Cloud to boost productivity

  It’s very important to have access to the workflow process from anywhere. Especially if you manage the work of others. There is no difference whether you’re out of office, or drive a ca...

265 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you