Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,569
Community Members
 
Community Events
176
Community Groups

Issues with simple JIRA automation

I have read a number of @John Funk posts here https://community.atlassian.com/t5/Marketplace-Apps-Integrations/Copy-a-value-and-pasting-it-into-a-different-field-Automation/qaq-p/1377239  and many others about automation -  it makes sense but after 4 hours of trying multiple ways to do this, I can't seem to get the automation working.  I am new to this so I must be doing something wrong but I can't figure out what. I did get the automation to run once successfully but I tried testing on another ticket it did not work and hasn't since.

We have:-
custom field called QA Story points  which is customfield_10053 
when the issuetype = Test and the QA Story points field is not empty  ie whenever it has any value different to 0 or has nothing in it then copy that value to the Jira stock Story Point field.

Sounds simple enough right ? :-(  I started with this automation as I wanted to start with something simple and I need to be able to do much more complicated ones next. Any guidance you can give would be appreciated

1 answer

0 votes

Hi @Paul Taylor 

Take a look at this rule.

copy-number-field.png

On issue update event it will copy the value from a number field to the story points fields.

Is your rule similar to this?

Ravi

thanks for the reply @Ravi Sagar _Sparxsys_   this is what my rule looks like currently. I started with something more simple, but when it didn't work I read some stuff and then started trying a bunch of different ways - none has worked.  To explain the logic....

when our QA story point field ( number field ) has any value other than empty or 0 i want to push the story points to the main JIRA story point field but only for issue types of Test

Snag_260b70.png

@Ravi Sagar _Sparxsys_  I believe the example that you gave is where I started before I started playing with anything to get it to work.  I went back to this and it does not work, am I doing something wrong here ?  

Snag_55a3996.png

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events