Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,545
Community Members
 
Community Events
176
Community Groups

JIRA bugs to ALM Defects Integration using ALM Synchronizer

I have JIRA bugs to Micro focus ALM Defects sync done using ALM Synchronizer. Our MF engineer credentials are updated to Generic user for both ALM and JIRA. We get successful connection check with ALM,but when check JIRA connection we get failure with following detail . Please suggest what could be the cause and how can we resolve this, as we can navigate to JIRA site with the same endpoint URL on the ALM Synchronizer server and while using same user credentials.

ERROR #1- adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type JIRA. Error: com.mercury.qc.gossip.exp.GossipServerException: server.RemoteExecService.UNHANDLED_EXCEPTION : Unknown exception type is caught: org.apache.wink.client.ClientAuthenticationException: Service failed to authenticate user: svcITQA........ERROR #2- server.RemoteExecService.UNHANDLED_EXCEPTION : Unknown exception type is caught: org.apache.wink.client.ClientAuthenticationException: Service failed to authenticate user: svcITQA........ERROR #3- Service failed to authenticate user: svcITQA.......

Thanks

Sumit

2 answers

0 votes

Hello @Sumit Shrivastava ,

I am not familiar with the ALM synchronizer myself but I found an accepted answer where another community member ran into a similar error viewable at the link below:

The solution they marked as accepted noted the following steps:

1. !!Backup jira-adapter.jar from your installation of ALM Synchronizer (e.g. C:\Program Files\Micro Focus\Micro Focus ALM Synchronizer\adapters\lib)
2. Download the zip file from the following link, extract jira-adapter.jar and replace it in the adapters\lib folder (e.g. C:\Program Files\Micro Focus\Micro Focus ALM Synchronizer\adapters\lib)
https://apacftp.microfocus.com/183762/f919601bc9a58a23dded8c8bf50a534f/supportline_download/Raji/jira-adapter-15.zip
3. Restart ALM Synchronizer service
4. Check the Jira connectivity

Let us know if this applies to your case as well.

Regards,
Earl

Hi Sumit,

I'm facing issue as mentioned by you. Can you please let know if you have got resolution on this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS

Atlassian Community Events