Still can't add images to Confluence Cloud pages. System Status page inaccurate.

Atlassian, it's not OK to claim you have fixed an outage and show your systems  are operational when it is not the case. I still can't add images to Confluence Cloud pages. This is a basic use case that should have been tested before claiming everything is fine again. 

This is not how you build trust with customers. I understand fixing problems takes time, and sometimes there are follow up issues. But that doesn't mean you should not be transparent and complete in your assessments and communication.

Extremely disappointed. On top of the recent large price increase, I am losing motivation to defend Atlassian products from the doubts of my business stakeholders.

1 comment

Funny enough, I tried to post an image of the status message here and that didn't work either.

Comment

Log in or Sign up to comment
Community showcase
Posted Thursday in Jira

Continuous visibility with the new Jira Software Cloud and Bitbucket Cloud integration

Hey Atlassian community, I am a PM on the Bitbucket Cloud team and I am excited to share that we just released an improvement to the Jira Software and Bitbucket Cloud integration. With the newly im...

128 views 0 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you