Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"Test" IssueType does not appear in the Issue Type Schema after installing Zephyr Squad

We got the Zephyr Squad installed from our Atlassian admin and it appears on our project side bar but when we go to "Create a Test" it does not do anything. We tried going to follow steps in the below article but the "Available Issue Types" does not show the "Test" issue type. Can someone please explain what are we missing here. The "Test" sub-task that you see below is a separate custom sub task we created and not added through Zephyr.

https://community.atlassian.com/t5/Marketplace-Apps-Integrations/How-to-enable-the-quot-test-quot-issue-type/qaq-p/455878#:~:text=I%20am%20not%20sure%20what,a%20option%20to%20be%20selected.

 

image.png

2 answers

1 accepted

0 votes
Answer accepted

Hi @Gaurav Shinde Get in touch with your JIRA admin for adding Test Issue type to your project Issue type scheme.

 

Thanks

Test Issue Type.PNG

If you are JIRA Admin, check General Configuration of Zephyr Plugin. 

Thanks Vikrant for your reply! The problem is the "Test" IssueType does not come in "Available Issue Types" in the "Issue Type Scheme" even after installing Zephyr Squad. Interestingly I cannot find the above checkbox you show in the screenshots in configuration too.

@Gaurav Shinde  These Checkbox availble in Plugin Configuration. 

Only Atlassian Admin or JIRA admin have permission to Check Plugin Configuration?

Kindly ask your JIRA admins to check plugin configuration and add This issue type in Issue type scheme ?

Check workaound provided by Zephyr for this issue :- 

https://support.smartbear.com/zephyr-enterprise/faq/issue-type-test-missing-after-installing-zephyr-fo/

Thanks

Thanks Vikrant! I will try the above out with our Atlassian Admin to see if it works. I have got the admin rights for our project and we checked the General Configuration for the plugin as the below screenshot suggests for some reason we dont see the "Test" IssueType we added to select. I guess this below list shows IssueTypes for all projects and hence its a big list. So possibly the last option would be uninstalling and re-installing Zephyr Squad to see if it works.Screenshot 2021-05-19 at 6.31.00 PM.png 

Project Admin dont have permission to access all Issue type or to manage Issue type Scheme. Project admin only add system issue types. JIRA admin have permission to manage Issue type Scheme. 

Hi Vikrant, So I asked our Atlassian admin to create an issue type in the project and assign it to a project scheme, then too it doesnt show up in the Plugin configuration to select in the dropdown. 

Hi @Gaurav Shinde  No need to create issue type, it already created when you install plugin. Admin only need to drag and drop issue type from Available Issue type to Project issue type sheme.

Yes we tried the above article too. The problem was that the issuetype wasnt already created when we installed the plugin because we had already an IssueType by the same name "Test" which caused the conflict. Renaming the existing issuetype, uninstalling and reinstalling Zephyr Squad fixed the issue

Like Vikrant Yadav likes this

Cool! Glad to hear it fixed ! 
Same thing mentioned in article I shared. 

So, we have managed to fix this by uninstalling and re-installing Zephyr Squad and maybe found the underlying issue. Before we installed Zephyr Squad we had an existing "Test" IssueType for our project which was a "Sub-Task". We tried renaming that to "Test Case" , then uninstalled Zephyr Squad and then reinstalled and it managed to give us a "Test" IssueType out of the box without us having to create a new issue manually.

Thank you @Vikrant Yadav for all your help!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Asked in Jira Service Management

JSM June ask me anything (AMA)

Hello Community members! We’re wrapping up the end of JSM June with an Ask Me Anything (AMA) with the Jira Service Management product team. This is your chance to ask all your ITSM questions to o...

262 views 13 14
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you