Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot create Epic

I'm trying to create an Epic in Jira Cloud.

 

From Backlog I open Epics and click 'Create Epic'.

Project is set and I enter the Summary (which should be the name of the Epic).

On clicking Create I see the error message "Epic Name: Epic Name is required."

I guess I need to add the Epic Name to a particular form but am not sure which.  If I click 'Configure Fields' in the upper right od the Create Epic box Epic Name is not available for selection.

 

Any ideas?

 

Cheers - Steve

 

9 answers

1 vote
Andy Heinzer Atlassian Team Sep 04, 2019

Hi everyone,

This problem was originally reported for Jira Cloud.  Since that time the problem in Cloud has been fixed. 

However Jira Server and Jira Data Center installs can still see this specific error when trying to use the 'Where is my field?' dialog box on an agile board create issue or create epic dialog box.   This is a bug.  We are tracking this specific bug in JSWSERVER-12965.

Fortunately, there is an easy work-around found on that bug ticket here:

Workaround

  • Instead of using the Board to create the Epic, use the Create Button in the top navigation bar to create the Epic. Following this method will permit you to use the 'Where is my field?' dialog without generating this error.

This alternative creation location will show you a slightly different create issue/epic screen.  If you are unable to create the issue/epic due to a missing field from the screen, you can use the Configure Fields -> Where is my field? option on this screen to work past this problem.

I hope this helps to clarify.

Andy

0 votes
Thomas Schlegel Community Leader Jan 18, 2018

Hi Steve,

which Issue Type is set in the form? If you set any other than Epic, the field Epic Name is not available.

Hi Thomas

The issue type is set to Epic.

Thanks,

Steve

0 votes

As an admin, go into the create screen again, and use the "configure fields" - you should see "where's my field" as an option.  This is really helpful, as it lists all the reasons your field might not be there, highlights any of the ones that are blocking it and links directly to where you can fix it!

Hi Nic and thanks for your suggestion. Unfortunately when I click "where's my field" I just see the spinning 'I'm doing something' indicator but nothing happens. It's been swirling for 90mins now :-)

same i am facing the exact issue while creating the EPIC and on clicking where's my field.

 

please help

It is odd. After dealing with this problem for a while, one day I just gave it another shot and the "Where's my field" button decided to work and I was able to do what I needed to. Perhaps update your browser, log out and back into your Jira account, etc. I have no idea what I did to experience different results. Good luck! I changed nothing about the project or my user privileges. 

I have the same problem in Jira Server.  The frustrating thing is that I have a number of Epics that I created successfully a few months ago, but don't appear to be able to create any more due to this 'Epic Name' requirement.

I have tried both the general 'Create' button at the top of every Jira page, and also from the Backlog page of a Kanban board in the Epic tab "Create Epic"

The epic name has always been required on Epics, you need to get it on screen.

Try the "where's my field" option on the create screen to quickly see what needs fixing to enable it to be there.

Nic, prompt as always!!!

What is the difference between an issue Summary and an Epic Name?  For all the Epics that I created before I don't recall having to enter two pieces of info.  It is possible that those were done using Portfolio for Jira (since abandoned - way too expensive for us beyond the trial) - is it possible that P4J auto-duplicates the Summary/Epic Name fields behind the scenes for convenience?

 

---

We just had to log a bug for the 'where's my field' as it produces the following error:

An error occurred

Please try refreshing the page, or contact your administrator / Atlassian Support if the problem continues.

Details

    • Exception: Uknown current dialog ID: create-epic-issue-dialog
    • Resource: https://XXXXX/s/50304f51de4e18829f4459672058de30-CDN/irmlea/78001/3303639c46f2a0c8179d22eba70d4c10/4.1.6/_/download/batch/com.atlassian.jira.plugins.jira-admin-helper-plugin:whereismycf-resources/com.atlassian.jira.plugins.jira-admin-helper-plugin:whereismycf-resources.js?locale=en-CA
    • Line: 153
    • Column: 1226

Environment

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1 Safari/605.1.15

I AM EXPERIENCING THE SAME THING.  The wheres my field button already has everything selected... Any other solution ideas?

Hi all, 

I'm in the same boat here. The 'configure fields' does not have Epic Name as a choice and the 'where's my field' button does not respond, only spins. Any suggestions? I was in an existing project and created a new scrum board to transition to instead of our kanban. Really need Epics in order to better organize. Did this several times yesterday on other existing projects doing the same exact steps and had zero issues. I've looked into issue type scheme settings and see not differences. Totally stuck on how to fix this. Thanks. 

Click on the "Where is my field?" link and search for the missing field. There was a period of time that I experienced an endless spinner after clicking on "Where is my field?" and then one day I tried it and it worked... I can't explain that one.

Thanks Matthew, saw your comment on this above so I guess I'll have to try daily to see if it resolves itself but it's definitely frustrating since I need this done asap. Wish I could figure out why this is happening on this board in particular. Thanks for the help. 

Like David_Guilfoyle likes this

Hello @Steve Mee and others,

If you are getting this error, please go to "where is my field" and check if 'Field Screen' is assigned to your project. If not, then Configure Screen and add 'Epic name' field to that screen.

It will resolve your problem.

I solved it with administration permissions. As an administrator, I went to the “issues” in “configuration” option. I went to “Issue Type Screen Scheme”. I select “Configure Issue Type Screen Scheme” and next, I select “Associate an Issue Type with a Screen Scheme”, where I select Epic Issue type and a Screen Scheme with “Epic Name” field included.

In other words, I configured the epic (within my project) with a ”Screen Scheme” that includes a “screen” that has "Epic Name" as an included field (included in Screen with "Configure Screen"). 

Epic Name - 2021-04-06.png

This worked for me.

Epic Name when Create - 2021-04-06.png

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

109 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you