Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,022
Community Members
 
Community Events
176
Community Groups

Using automation to update Insight object date attribute

Hi,

Perhaps someone can spot my error or guide me on using automation to update an insight object date field. My automation fires, and gets a 200 response, but the attribute value does not change.

Scenario:
I have an insight schema containing a table of objects which represent tasks to be done at predetermined times.

I'm creating an automation rule that performs an IQL query to select the objects representing tasks which need to be done today. The results of this query are used to generate issues, one per object, and then to update the insight object with a "last run" date the current date.

  • Currently, manual trigger is used while testing
  • IQL identifies the correct objects
  • If block with advanced compare sets up for processing of result list
  • For each block implements list smart value
  • The Create Request step does indeed creates all the necessary requests, including updating an object custom field with the details of the insight object that relates to the new issue
  • A Send web request step pushes an update to the API for that object, and waits for results
  • A final mail step (for debugging) send me the details of the return object - headers and body - which I believe confirms that my request URL and authorization must have worked. The return code is always 200

The problem is that the web request to update the date does not update the date, nor does it throw any errors.

The code looks like this:
{
"attributes": [
{
"objectTypeAttributeID": "384",
"objectAttributeValues": [
{
"value": "{{now}}"
}
]
} ]
}

I have triple checked the objectTypeAttributeID - it is correct for the attribute I want to update and it is a date object.

If I use a literal instead of the smart value for the date, the result is unchanged.

What trick am I missing?

1 answer

Hi,

 

You've to add .jiraDate

{{now.jiraDate}}

 

Laurent

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events