Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

AuthenticationFailedException: AUTHENTICATE failed

I'm evaluating JIRA Service Desk and I cannot get my exchange server connected in as the incoming mail source. When I enter the information for my server and test it I get the error: "AuthenticationFailedException: AUTHENTICATE failed."

I searched the knowledge base and found this article: https://confluence.atlassian.com/display/JIRAKB/Authenticate+Failed+Error+when+Connecting+to+Exchange

I then added -Dmail.imap.auth.plain.disable=true and -Dmail.imaps.auth.plain.disable=true to the setenv.sh file in the JVM_SUPPORT_RECOMMENDED_ARGS section. Then restarted the JIRA service. This did not work, same error message.

I turned on email debugging by adding the -Dmail.debug into the same section and file referenced above. (The setenv.sh file I'm working on is located in /opt/atlassian/jira/bin by the way). Then I tried to test again and got the same error message.

After combing through the logs I pulled this line out: 

http-bio-8080-exec-11 ERROR <username> 911x91x1 1u33boo <my ip address> /secure/admin/VerifyPopServerConnection!update.jspa [plugins.mail.webwork.VerifyMailServer] Unable to connect to the server at <email server name> due to the following exception: javax.mail.AuthenticationFailedException: AUTHENTICATE failed.

I'm combing through the knowledge base and forums and cannot find anything relevant. My JIRA server is linux, my exchange is 2007 and I'm trying to connect via IMAP. 

I've tried different user names, that doesn't change the error. I've tried referencing the email server by ip address and by DNS name, that doesn't change the error. My server can ping the email server. The username I'm using has full admin rights on the mail server.

Any help is appreciated as I'd really like to try this software out.

2 answers

After searching my server I find only one setenv.sh file. Also the log file I'm looking at is catalina.out inside /opt/atlassian/jira/logs/

The article you link indicates that Exchange has been configured to deny plain auth.  You can't fix that with and configuration of JIRA, its an exchange setting, perhaps this helps:

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

326 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you