unsupported collation: Latin1_General_CI_AI after update

Man i dont know what the heck my problem is with jira, but i keep having issues that are really stupid. Case and point, i have tried to reinstall jira helpdesk to fix another issue and after the upgrade, and copying over the SSL connector manually to server.xml (sigh), i get this lovely message (below)

 

So I have a few problems with this. For one, is it just complaining that I dont have the SQL prefix in front of the collation?

And two, in sql server 2016, the SQL prefix infront of latin1_general_CI_AI doesnt even exist!!!!

so i am supposed to change the collation to a collation type that the sql server does not have? wtf man. i just clicked ignore but damn, this feels like some sort of bug here.

pissing me off.pngjira collation.png

 

1 answer

0 vote

Hi,

Please take a look at the Supported Platforms for JIRA.  In addition, take a look at Health Check: Database Collation in Microsoft SQL Server.

At this time Atlassian supports the following MSSQL versions:

  • 2014
  • 2012

One thing to note is that I do see SQL_Latin1_General_CP437_CI_AI in your list so you may try that.

I would recommend installing a supported version and if you're still running into this issue please vote on JRASERVER-59378.

Cheers,

Branden

i dont know what that numbered collation means or the significance of changing it. I do know that it takes a bit of work to change. So i wont be changing it.

 

But i think you should update your software to not complain at me about an issue which probably isnt an issue.

jira doesnt support microsoft sql server 2016? extremely popular software that is at least 2 years old at this point?

 

uh and beside that, the health check page you sent me reports that the non sql collation IS supported in the first place!!!! i knew it would be becuase i payed attention to that when i was setting up jira only a few months ago

 

collation probs.png

 

and just to reinforce the point, my health check reports the following:

reinforcement.png

 

so i stand by my contention that this is some sort of bug.

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published Friday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

64 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot