HipChat for JIRA: Log Error

Hi,

After installing the latest version of HipChat for JIRA. I keep getting this error in my logs literally every 2 seconds...

 

2014-10-06 13:48:47,879 hipchat-client-io:thread-10 ERROR [http.nio.protocol.HttpAsyncRequestExecutor] http-outgoing-250 [CLOSED] HTTP protocol exception: null
java.nio.channels.ClosedChannelException
at sun.nio.ch.SocketChannelImpl.ensureReadOpen(SocketChannelImpl.java:252)
at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:295)
at org.apache.http.nio.reactor.ssl.SSLIOSession.receiveEncryptedData(SSLIOSession.java:340)
at org.apache.http.nio.reactor.ssl.SSLIOSession.isAppInputReady(SSLIOSession.java:366)
at org.apache.http.impl.nio.reactor.AbstractIODispatch.inputReady(AbstractIODispatch.java:118)
at org.apache.http.impl.nio.reactor.BaseIOReactor.validate(BaseIOReactor.java:220)
at org.apache.http.impl.nio.reactor.AbstractIOReactor.execute(AbstractIOReactor.java:284)
at org.apache.http.impl.nio.reactor.BaseIOReactor.execute(BaseIOReactor.java:106)
at org.apache.http.impl.nio.reactor.AbstractMultiworkerIOReactor$Worker.run(AbstractMultiworkerIOReactor.java:604)

 

Any ideas?

3 answers

We have the same on our Confluence instance. This is real pain!! Atlassian, appreciate some input here please.

0 votes
Ahmad Danial Atlassian Team Jan 08, 2015

Miguel and Ricardo, can you please try to see if enabling Safe Mode helps? Is it affecting your JIRA / Confluence instance in any way? I am suspecting that it might be related to one or more installed plugin(s) that you have on your instance(s).

Hello,

I'm facing the same problem.

Similar log entries appear couple of times per second, thus filling our logfiles.

JIRA version 6.3.9

I've removed all old hipchat plugin files as recommended and restarted JIRA service but it didn't work.

Entries doesn't appear after service restart for some time (minutes/hours) so I suppose it may start after first connection between JIRA and hipchat. I will try to setup HipChat server in staging environment and check if this problem can be reproduced. I can't switch to safe mode on production.

Do you have other solution?

Is there a way to turn off logging these entries?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 10, 2018 in Hipchat

What should I think about when migrating HipChat to Slack?

...from the beginning. We have built up a lot of content in HipChat, with it being a core tool in our distributed company model. While it is true that we didn’t need to move to Slack immediately, we felt it...

493 views 1 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you