SourceTree 1.8 Git Flow not working

Hi,

i upgrade today to SourceTree 1.8. After that i can't create a new Feature. And a co-worker can't complete his feature. I seems that Gif Flow is broken.

I will try downgrade to 1.7.

Btw. Please add the Git Flow button to the navigation again.

Thanks Marco

 

24 answers

This widget could not be displayed.

Gitflow init and creating a hotfix does not work here

This widget could not be displayed.

I'm having the same issue. I'd usually use GitFlow to close my feature branch, but since the update it doesn't recognise that I have any feature branches.

This widget could not be displayed.

Here is the error I get in SourceTree:

sh.exe C:\Users\maxwellb\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow feature start <branchname>
Completed with errors, see above.
This widget could not be displayed.

In case anyone else is having trouble with this, you can download the previous version from 
https://downloads.atlassian.com/software/sourcetree/windows/SourceTreeSetup_1.7.0.32509.exe 

This widget could not be displayed.

@Brent Maxwell thanks for posting the error message. It's the same one i get.

 

This widget could not be displayed.

Same here, can't finish my feature after updating to 1.8.

This widget could not be displayed.

ERROR [2016-02-16 14:37:03,225] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo

This widget could not be displayed.

Same problem.

"Fixed" by removeing source tree and reinstalled version 1.7

This widget could not be displayed.

Nice one Atlassian! Thanks for the "upgrade" and wasting half an hour of my day.

This widget could not be displayed.

Same problem as the OP.  "upgrading" to 1.7

 

This widget could not be displayed.

Fixed by reinstalled version 1.7

This widget could not be displayed.

Atlassian have definitely introduced a bug here. They're trying to execute a file that doesn't exist.

Using Process Monitor from SysInternals (part of Microsoft), I can see that SourceTree is trying to run mingw32\bin\sh.exe. It's trying every directory in the PATH environment variable, but isn't able to find sh.exe to run it.

I've had a look for where copies of sh.exe might be, and have found:

  • SourceTree embedded Git (2.6.1): %localappdata%\Atlassian\SourceTree\git_local\bin\sh.exe
  • Git for Windows (1.9.5 and 2.7.1.2): %install_dir%\bin\sh.exe

In other words, the path is always %git_base_dir%\bin\sh.exe.

Also, when launching sh.exe, the full path to the executable should always be used. The current method is falling back to a search of the PATH, which is both inefficient and may result in the execution of a completely different sh.exe.

This widget could not be displayed.

Same problem. Trying to start a feature.
SourceTree tries to run:

sh.exe C:\Users\<username>\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow feature start sales_pricing

and fails with quite unhelpful message:

Completed with errors, see above.

I tried to run this command from command prompt and saw that Windows can't find sh.exe.
I tried to add

C:\Users\<username>\AppData\Local\Atlassian\SourceTree\git_local\bin\

to PATH. Didn't help. SourceTree was still showing the same error.

When I tried to run this command from command line while in C:\Users\<username>\ folder, it ran and showed this message:

fatal: Not a git repository

I switched the current folder to the one that has .git in it and then it ran successfully and SourceTree picked up that there is a new feature created.

It seems that the new version of SourceTree is not setting the current folder properly when trying to run git flow commands.

This widget could not be displayed.

I've just got a notification from Atlassian regarding this:

The latest release of SourceTree for both Windows and OSX contains several bugs that were discovered after release. We have a new version of both apps going out in the next 24 hours which should address the following issues:
https://jira.atlassian.com/browse/SRCTREE-3395
https://jira.atlassian.com/browse/SRCTREE-3387
https://jira.atlassian.com/browse/SRCTREE-3402
https://jira.atlassian.com/browse/SRCTREE-3384
https://jira.atlassian.com/browse/SRCTREE-3400
https://jira.atlassian.com/browse/SRCTREEWIN-4167
https://jira.atlassian.com/browse/SRCTREEWIN-4177
https://jira.atlassian.com/browse/SRCTREEWIN-4238
https://jira.atlassian.com/browse/SRCTREEWIN-4182
https://jira.atlassian.com/browse/SRCTREEWIN-4192
https://jira.atlassian.com/browse/SRCTREEWIN-4169
https://jira.atlassian.com/browse/SRCTREEWIN-4230
https://jira.atlassian.com/browse/SRCTREEWIN-4207
https://jira.atlassian.com/browse/SRCTREEWIN-4301
https://jira.atlassian.com/browse/SRCTREEWIN-4200
https://jira.atlassian.com/browse/SRCTREEWIN-4331
https://jira.atlassian.com/browse/SRCTREEWIN-4348
https://jira.atlassian.com/browse/SRCTREEWIN-4219

In addition, we will also be bringing back the Git Flow button to the main top nav bar to both new versions. For OSX, you can access it by right clicking on the menu bar and selecting customize toolbar once the new version of the app has been installed.

It looks like a fix will arrive soon.

This widget could not be displayed.

I wonder what kind of regression testing they use before release? It looks like there was no testing at all ...

 

This widget could not be displayed.

sh.exe C:\Users\FANSHAOYONG\AppData\Local\Atlassian\SourceTree\gitflow_local\gitflow\git-flow feature start redux
完成时带有错误,见上文。

I have the same error~~

This widget could not be displayed.

Same issue here... reinstalled 1.7

This widget could not be displayed.

Wow, so, the current solution its unistall and install an old version...

This widget could not be displayed.

Still no update?

This widget could not be displayed.

same issue.. I will wait for the fix

This widget could not be displayed.

I can't use this version at all.  It doesn't recognize my built-in Git which has a bunch of critical settings, and I can't figure out where to add them to the "embedded git" for ST.  This is absolute garbage and I am utterly disappointed in Atlassian for ever accepting such trash in an official release of their product.

This widget could not be displayed.

Source Tree 2.2.3 and still no git flow feature.

This widget could not be displayed.

Hi, I have the same problème, but just when I use the graphical acces

It work when I tape command, strange Noooo!!

eg: git-flow init -d

Because I'm not so good at command line, I hope someone tell me how to fx it. Thnx

This widget could not be displayed.

I have downloaded the latest version 1.9 and still facing the same issue. I can't finish my feature. Did anyone find a solution to this problem?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Sep 17, 2018 in Teamwork

The tools we make for teams? We use them every day at Atlassian to get shit done (and it works).

I’m Jess, a Product Marketer for Jira Software Server and Data Center, and now a huge fan of our products. Read on for a 90 day, new-hire perspective on what it’s like to standardize on the Atlassian...

150 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you