Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

java.lang.RuntimeException - com.cenqua.fisheye.LicensePolicyException: Your FishEye license is missing or invalid.

Hi. Went to login to FishEye and am getting the following error:

java.lang.RuntimeException - com.cenqua.fisheye.LicensePolicyException: Could not add user xxxxxxxx. Your FishEye license is missing or invalid.

com.cenqua.fisheye.LicensePolicyException: Could not add user xxxxxxxxx. Your FishEye license is missing or invalid.

Could not add user xxxxxxxx. Your FishEye license is missing or invalid.

You are running release FE2.8.0 (20120814071112 2012-08-14), please report your release number when reporting bugs.

My license is current. I figured I would check on the status of my license as a first step in the troubleshooting process. When I go to view my license in https://my.atlassian.com/products/index specifically at this link: https://my.atlassian.com/products/editserverid/xxxxxxx it asks me for my Server ID. The problem is I can't get at my Server ID in FishEye because it won't allow me to login per the problem I am having.

Not sure how to proceed or what needs to be done.

thanks

1 answer

1 accepted

1 vote
Answer accepted

Hi Steve,

As per our support case the issue happened because FishEye was using an expired license. So the issue was solved when the license was upgraded.

I'm sharing the resolution of the support ticket here for future references of the comunity users.

Cheers,

Leonardo.

Hello.

As we have the same error in our logs (Fisheye 3.1.5) I would be interested if there was a resolution of the support ticket.

Our situation:

We have several Jira users and a few developers. The rights to view the "source Tab" are limited to the devs, but if there is one cklicking this tab and the license is ecxeeded there is an error message:

Request to <SERVERURL> failed: Error in remote call to '<SERVERNAME>' (xxx) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=<JIRA-ISSUEKEY>, expand=changesets[0:100].revisions[0:99],reviews}, methodType=GET}] : Received status code 500 (Server Error)

But it is possible to click the <SERVERURL> which caused than the exception.

Nevertheless I will issue an extra ticket, just curious if you something of that relates to your support ticket.


Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

483 views 16 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you