Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to index repository Edited

Hi,

I did upgrade the fisheye/crucible from 4.1 to latest 4.5.2 .Fisheye fails to index the SVN repository. And the following error message is appearing at UI when trying to start the repository:

can you please advise

svn issue.jpg

1 answer

1 accepted

0 votes
Answer accepted
Thomas Deiler Community Leader Feb 02, 2018

Dear @Tummala,

just to validate your credentials, can you create a new repo with the upper credentials and see if fisheye can connect?

So long

Thomas

Hi Thomas,

1. The repo URL, username/pwd are correct - tested it via web browser

2. I had other repos setup in our Fisheye and it's running fine no issues with indexing.

 

Thanks

Thomas Deiler Community Leader Feb 02, 2018

So the issue remains only at one repository?

yes.

Did something change with svn client in new fisheye 4.5.2 version?

Thomas Deiler Community Leader Feb 02, 2018

Ok. Then please create a new repository beside the one, that is not working, with the same credentials.

I am not able to create a new repository with same credentials .

when clicked on Test connection I got same error 

Thomas Deiler Community Leader Feb 02, 2018

Perfect! Then I recommend to disable the old and continue with the new. It seems that there is some kind of data, that got corrupted.

HI Thomas,

 

I am getting the same error for all the repos. What is the problem why it is not working for me. Can you help me to solve this issue. recently i have upgraded the version 4.5.2 but previously it was in 4.5.1 that time also it was not working.

Thomas Deiler Community Leader Feb 06, 2018

Don't get you - now all repos have errors? You wrote some post before, that only one repo had the error.

To help you best, can you give me more information on what you currently configured? Some screen shots perhaps?

so long

Thomas

Hi Thomas,

 

sorry for the delay , i am still having issues when creating new repos after the upgrade.

existing repos work fine no issues.

Are there any issues with SVN client with version 4.5.2?

i was looking at this article https://confluence.atlassian.com/fisheye/svn-authentication-issues-298977099.html

any help appreciated,

Thanks

Thomas Deiler Community Leader Feb 06, 2018

Dear @Tummala,

have you tried to connect on command line from your Fisheye Server

svn co svn://host/repo 

So long

Thomas

I  get the below errorsvn issue002.jpg :

Thomas Deiler Community Leader Feb 06, 2018

Dear @Tummala,

can you do a

nmap <hostname>

to see which ports are open? But so far it seems there is no route to the host. If you cannot connect via Command line, fisheye will also not work.

So long

Thomas

Hi Thomas,

sorry for the delay , the problem in my scenario was the user did not have access to the folder level in SVN repo when added access . I was able to setup repo in fisheye and test connection was successful. Appreciate your time for looking into it.

Thanks again!

Thomas Deiler Community Leader Feb 07, 2018

Dear @Tummala,

glad, that your problem is solved. Anyway, if you found my support useful, and it could be also useful for others, please "accept" the top most answer.

Many Thanks

Thomas

Done. Thanks again for troubleshooting tips.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Comparison between Zephyr & Xray

I am sharing this article with both Zephyr and Xray information and everything should be in one place. It will be easy to know when selecting Zephyr or Xray. Zephyr and Xray are both Jira plug-ins u...

180 views 1 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you