Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,080
Community Members
 
Community Events
168
Community Groups

Unable to add repository into Crucible

Hi

I'm in the process of evaluating Crucible, but I can't seem to get it too add in my Git repository.

I keep getting the following error.

Error testing connection.
Error talking to repository: 


at com.atlassian.fisheye.git.GitScmConfig.testConnection(GitScmConfig.java:148)
at com.cenqua.fisheye.RepositoryConfig.testConnection(RepositoryConfig.java:444)
at com.atlassian.fisheye.spi.admin.impl.DefaultRepositoryAdminService.testConnectionFor(DefaultRepositoryAdminService.java:567)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

Connection failed.

I've pasted in the repository name from repository details shown within Stash. If I use this URL in the browser the repository is displayed, not sure what else to try.

Can anyone help?

Thanks

Martin.

10 answers

1 accepted

4 votes
Answer accepted
Jeff Thomas Atlassian Team Nov 17, 2013

Martin: Are you using a URL similar to one of the two formats below?

https://user@server:port/scm/project/repository.git

ssh://git@server:port/project/repository.git

Also, are you able to clone the repository using Git as the user running Crucible?

git clone https://user@server:port/scm/project/repository.git

If cloning over SSH using the default SSH port (22), you can also use this form:

git@server:proejct/repository.git

Deleted user Nov 07, 2018

This is my first time setting this up, so I wonder how you could determine what port or what path or where should I put the git executable

In the Attlassian documentation, I found that we need to download git for OS and set the path of git executable, once I put that, I was able to add. See the below link of how to set the path.

https://confluence.atlassian.com/display/FISHEYE/Git+client

I posted this earlier in wrong place.... here again..

In the Attlassian documentation, I found that we need to download git for OS and set the path of git executable, once I put that, I was able to add. See the below link of how to set the path.

https://confluence.atlassian.com/display/FISHEYE/Git+client

same here

I could not add the Git repository and getting the same error as Martin has pasted. I tried this url, https://user@server:port/scm/project/repository.git

but no luck. I could connect to the git in browser. I am running evaluation version

3.4.5

Hi Tim,

Per our email correspondence, please feel free to file a ticket in the Crucible project on support.atlaassian.com to ensure the quickest response from Atlassian tech support in the future. Thanks guys!

Any new thoughts on this? I'd love to continue our evaluation of your product but I can't get to first base. Thanks!

Tried it, still not working. I didn't mention earlier I'm also getting file-delete errors but I thought the connection problem was the primary issue. I'm still getting them, like:

problem deleting directory e:\build\CrucibleInstance\var\tmp\hg_test_clone_1384880057202\.hg\store\data\_production\_command_line\_print\_print_response

I'm not sure what the "problem" is since the directories do seem to get deleted, and I'm full Admin on the machine for the user I'm trying (also tried a non-admin user and pointing to his own documents directory).

So I'm not sure if the 2 issues are related, but I still can't get going to evaluate. This is on a Windows7 machine running bin\start.bat (not a service). What else can I try?

I'm having the same problem during an evaluation, getting a failed test connection. The url I'm using works fine in the browser, of a format like:

https://pdxhg.xx./phm

How would I "add the username/pwd to the url" as the first person said?

Jeff Thomas Atlassian Team Nov 18, 2013

When you're adding the repository on page 2, there is a section for Git Authentication where you can choose Password for http(s).

To specify the username, add it to the URL:

https://user@server:port/scm/project/repository.git

sorted it, I didn't have a user name in the URL, and I didn't realise you needed to put in the password as well.

thanks for your help.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events