Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trouble connecting FishEye to Apache

I can't seem to connect FishEye to Apache. I followed the docs online for Fisheye 2.6.1 to set up a proxy, but that doesn't seem to work. I just get redirected to a blank page. I have Jira connected to the same Apache instance through an AJP connector, but the documentation for FishEye's AJP connector is a little slim and I haven't gotten it to work. Has anyone had any luck fronting FishEye with Apache?

4 answers

1 accepted

0 votes
Answer accepted

I was able to get this to work, my Jira configuration was overriding my proxy pass. It should be obvious, I just figured AJP handled the fact that I was redirecting / to it. Anyway, my final confiugration looks like this:

httpd.conf

ProxyRequests Off

ProxyPreserveHost On

<Proxy *>

Order deny,allow

Allow from all

</Proxy>

#Jira

ProxyPass /jira http://bkc-dev-collabnet.llnl.gov:8086/jira</p<>>

ProxyPassReverse /jira http://bkc-dev-collabnet.llnl.gov:8086/jira</p<>>

#Confluence

ProxyPass /confluence http://localhost:8087/confluence</p<>>

ProxyPassReverse /confluence http://localhost:8087/confluence</p<>>

#Fisheye

ProxyPass /fisheye http://bkc-dev-collabnet.llnl.gov:8060/fisheye</p<>>

ProxyPassReverse /fisheye http://bkc-dev-collabnet.llnl.gov:8060/fisheye

and then my Fisheye Config:

<web-server context="fisheye">

<http bind=":8060" proxy-port="80" proxy-scheme="http" proxy-host="hostname"/>

One issiue i did have is that specifying the proxy-host in Jira i used a fully qualified path, as in http://hostname, but in Fisheye that redirects you to http://http://hostname, so drop the http://</p<>>

Hi guys, thanks for writing in. So here's my relevant part of the http.conf

#Jira

ProxyPass / ajp://bkc-dev-collabnet:8009/

ProxyPassReverse / ajp://bkc-dev-collabnet:8009/

#Fisheye

ProxyPass /fisheye http://bkc-dev-collabnet.llnl.gov:8060/fisheye</p<>>

ProxyPassReverse /fisheye http://bkc-dev-collabnet.llnl.gov:8060/fisheye

I'm trying to serve both Jira and Fisheye, and it's worth noting that Jira works just fine through the ajp connector. I had trouble with a standard proxy pass for it as well, but with Tomcat that was no big deal to work around. I tried ajp for Fisheye as well but no luck

Here's the relevant Fisheye Config for Proxy pass I have setup

<web-server context="fisheye">

<http bind=":8060" proxy-port="80" proxy-host="myhost" />

</web-server>

Thanks

Mod_proxy is the easiet way to do this as Jamie says ( make sure all the necessary modules are enabled in Apache.)

If you want to post your conf files will be easier to see what you are doing.

Do you need to do it via ajp13? I just have:


ProxyPass /fisheye http://f.q.d.n:8060/fisheye<br< a=""> />
ProxyPassReverse /fisheye
http://f.q.d.n:8060/fisheye

Also you need to make sure you have changed the context root in fisheye and then restarted Fisheye for it to take effect. Maybe worth trying to get it working with mod_proxy before ajp13?

Yes this is exactly how I have it now. I posted my httpd.conf below, I had a conflict that prevented this. Thanks!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

551 views 15 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you