Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Setting the FISHEYE_INST environental variable

Hi Everyone,

I have just attempted to upgrade my Crucible install from 2.7.3 to 2.7.4

I did NOT have the FISHEYE_INST variable set in the initial installation.

But following the instructions in the Upgrade notes I created one.

(and copied the var/cache/data/config.xml files to the new FISHEYE_INST location).

Now when I start 2.7.4 I do not see my old repositories.

In adminsitration / sysinfo I see the FISHEYE_INST variable is set to the FISHEYE_HOME path.

I edit ~/.profile and set the variable with;

export FISHEYE_INST=/Applications/Atlassian/atlassian-fecru-data/

echo $FISHEYE_INST displays the above path as expected.

(I even added the export command to /etc/profile)

I have closed and then opened a new terminal window / I have even rebooted the machine.

Regardless, the INST variable is not being correctly reflected when Crucible starts.

If anyone has any ideas - I would be most grateful!


3 answers

1 accepted

0 votes
Answer accepted

With some thanks to the link above by Eddie,

I have managed to get it working using the correct location for FISHEYE_INST

In bin/ is the following line;

if [ -z "$FISHEYE_INST" ] ; then

I assume, that for some reason that test for the INST variable does not work on Mac OS X.

I changed it to;

if [ -z "$FISHEYE_INST" ] ; then

And Crucible has started correctly - with my existing repo and commits / reviews.


I am just starting with setting up Fisheye (the current version is 3.0.2).

I am experiencing the same problem that Gavin had - $FISHEYE_INST is set, and the system sees it as it should be. However, Fisheye doesn't. It uses <Fisheye-install-directory> - which Atlassian stresses one shouldn't be doing !!

Thanks, Gavin, for your tip.

Since mine is a new install, if I hadn't checked the settings, I would have had a hard time when doing an upgrade - would have "lost" all my repositories/info

It's definitely something to do with the scripts. I'm running CentOS - maybe the scripts don't work for this distro but works for others. (I noticed that Attlassian seems to offer more "support" for Ubuntu, or at least, it seems Ubuntu is more preferred)

Charlie Misonne Community Leader Oct 12, 2017

Same issue today on CentOS.

Hardcoding the path in solves it

0 votes
EddieW Rising Star Oct 04, 2011

You need to copy more than just config.xml to the INST (instance) directory you specified. Without the additional files (namely var and cache) being present there it will not be able to read any of the data associated with the repos defined in config.xml. Or at least, that was my experience.

Unfortunately it make take a bit of trial and error to get it right, as Fisheye's documentation is one that consitently lags behind the rest.

But at least this page does list what the end goal should be in terms of data locations.

Hi Eddie,

The upgrade documentation has appropriate notes about copying var/cache/data and the config.xml file.

(I did state above that I had dome these things, too.)

I am not convinced that I have a "file" issue.

I am petty certain that my issue is that the FISHEYE_INST environment variable is not being "picked-up" by Crucible when it is run.

echo $FISHEYE_INST - shows the correct path.

But Crucubles sysinfo tab shows the HOME directory as being what is set for FISHEYE_INST

If I could work out how to get it to use the correct path in the first place... I think I'd at least but further along.

Thanks again... but it seems to be something else, other than a mising file that is causing my issue.


Suggest an answer

Log in or Sign up to answer

Atlassian Community Events