It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Repository settings problem

TamasS Jun 10, 2013

Dear All,

we try to configure a SVN repo to our Fisheye. The test connection fails everytime however:

1. The repo URL, user/pass are correct - we tested it via web browser

2. The same URL host is set to a different repo in our Fisheye and it's running so there is no firewall or proxy issue here

We have no idea what is it behind the problem...:(

The URL is: http://xxx.xxx.xxx.xx/svn/xxx

How can we set it?

Can you please help?

Thanks, in advance,

Rumi

6 answers

1 accepted

0 votes
Answer accepted
Conor MacNeill Atlassian Team Jun 11, 2013

Subversion is refusing permission to access the repo. You should check the following:

  1. You have configured a username and password for the repository in the repository configuration
  2. The operating system user that is running FishEye does not have any cached Subversion credentials. Look in .subversion/auth.

TamasS Jun 12, 2013

hi Conor,

for the repository there are user/pw configured - if this is what you mena in point 1.

For the 2nd point: there is an "svn.ssl.server" folder under the .subversion/auth folder. What should we check here?

Thanks in advance for help!

Tamas

0 votes
Kah Loun Foong Atlassian Team Jun 10, 2013

Hi Rumi,

Please at least give us the test connection failure message so that we can check on it.

0 votes
TamasS Jun 10, 2013

Unable to get info for the repository root for XXX
svn: E170001: OPTIONS of '/svn/XXX': 403 Forbidden (http://xxxx.xxx.xxx.xxx.xx)
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:731)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:362)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:350)

Unable to get Repository Root URL for XXX:http://xxxx.xxx.xxx.xxx.xx/

Exception getting FishEye access control
svn: E170001: PROPFIND of '/svn/xxx': 403 Forbidden (http://xxxx.xxx.bud.xxx.xx)
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:731)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:362)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:350)

Error testing connection.
svn: E170001: PROPFIND of '/svn/xxx': 403 Forbidden (http://xxxx.xxx.bud.xxx.xx)
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:731)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:362)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:350)

Connection failed.

0 votes

Hi Guys,

Kindly provide the solution for this. I am getting the same error while changing the svn repository password in fisheye.

Unable to get info for the repository root for Luxor
svn: E170001: OPTIONS of '/svn/xxx/xxx/cache/aaa': 403 Forbidden (https://subversion.apps.com)<br< a="">>at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:731)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:362)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:350)

Unable to g...


https://subversion.apps.com)<br< a="">>at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:731)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:362)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:350)

Error testi...
https://subversion.apps.com)<br< a="">>at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:731)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:362)
at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:350)

Connection ...

0 votes

Try add

SecRule REQUEST_METHOD “^(PROPFIND|PROPPATCH)$” allow
SecRule REQUEST_METHOD “^(REPORT|OPTIONS)$” allow
SecRule REQUEST_METHOD “^(MKACTIVITY|CHECKOUT)$” allow
SecRule REQUEST_METHOD “^(PUT|DELETE|MERGE)$” allow

to modsecurity_crs_10_config.conf then restart httpd

0 votes
Richard Kiefer Aug 15, 2018

We are currently evaluating Crucible 4.6. We also got this error. We identified the root cause. Our setting:

* different projects unter the same svn root, i.e. they all share the same revision counter, or, put differently, they are all subfolders of the same repository

* we add repository http://svn/project1 to Crucible, with user user1. That user has only access to project1, not to project2.

* we add repository http://svn/project2 with a different user2, which has access to project2 only.

We get the above mentioned forbidden error on repository with project2.

Root cause, as it seems: Crucible uses the user1 from project1 to access project2, and neglects the user2 completely. This seems to be a caching issue/bug with user credentials, maybe caused by the fact that both projects reside in the same svn-repository, namely http://svn/

Workaround: configure the svn-URL of project2 to be http://user2@svn/project2. Then, Crucible does use the specified user credentials.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Marketplace Apps & Integrations

Webinar alert! An IT Admin's Guide to Securing Collaboration at Scale

Hello, Atlassian Community! My name is Dave Meyer and I'm a Principal Product Manager at Atlassian. I wanted to give this community a heads up about an upcoming Webinar that might be of interest...

162 views 2 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you