Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Receiving "The database is not using Unicode. Crucible requires that the database uses a UTF8 encoding to support internalization".

I am receiving this error when I attempt to test the Fisheye connection, even though I unchecked the Crucible option during the initial setup.

I setup a mySQL database and user as seen below. The SQL database is running on a separate server from the Fisheye install.

CREATE DATABASE fish_db character set utf8;

CREATE USER 'fishdbuser'@'%' IDENTIFIED BY 'passwd';

GRANT ALL PRIVILEGES ON fish_db.* TO 'fishdbuser'@'192.168.200.14' IDENTIFIED BY 'passwd' WITH GRANT OPTION;

On the Database Configuration page my settings are:

Type: MySQL

Driver Location: Bundled

URL: jdbc:mysql:192.168.200.14:3306/fish_db

User Name: fishdbuser

Password: passwd

Minimum Pool Connections: 5

Maxiumum Pool Connections: 20

Parameters: useUnicode=true

characterEncoding=UTF8

connectionCollation=UTF8_bin

I've logged into the SQL server and performed the following with success:

use fish_db;

show databases;

+--------------------------------------+

| Database |

+---------------------------------------

| information_schema |

| crowd_db |

| fish_db |

| jira_db |

| mysql |

+---------------------------------------+

As you can see, I have both jira and crowd databases working from this same instance. I don't understand why Crucible is even being considered when I unchecked the box for the Crucible setup.

I've dropped the database and user a few times and recreated, but that hasn't resolved the issue. I've flushed the privileges as well, but nothing seems to work.

2 answers

1 accepted

0 votes
Answer accepted

Use collation utf8_bin for the database and it should work.

Hi All,

I am getting the same error for MSSQL server 2008. I have given connectionCollation='SQL_Latin1_General_CP1_CI_AS' but same error.

Can any one please guide what are the require parameters need to defined for SQLSERVER2008 connection?

Thanks,

Suchi

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence Cloud

🎨 Add some visual life to your templates

Hi Atlassian Community, My name is Avni Barman, and I am a Product Manager on the Confluence Cloud team. Based on feedback from you, we are giving admins more power to create templates that a...

226 views 4 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you