Issues creating repository with SSH

Hello, i am trying to connect Crucible 3.4.0 version to my SVN repository using svn+ssh. I can add a new repository and test the connection and it works fine. Also i can browse the repo in fisheye. When I first add the repository Crucible scans the repo fine and is able to scan all the changesets which i am also able to view. However i get an Authorization exception when Crucible attempts to index the changesets. Which is kind of strange. Any ideas on why this is happening. i had the same issues with 3.3 versions as well.

com.cenqua.fisheye.rep.RepositoryClientException: org.apache.subversion.javahl.ClientException: svn: E170001: Authorization failed org.tmatesoft.svn.core.SVNAuthenticationException: svn: E170001: Authorization failed

When i look up the scan status, it shows that the scanning of the changesets is 100% complete but indexing changesets is at 0% and stopped because of this.

Also jsvn worked connecting to my repo.

2 answers

0 votes
Nick Pellow Atlassian Team May 11, 2014

Can you run with DEBUG logging enabled and then try and run the same svn commands that are failing as the same user that fisheye is connecting with, from the svn command line.

Indeed if the Scan completes with no Auth errors, then so should the Index.

I am trying to migrate from 1.6.3 to 3.4.0. I know this is big leap. what is the best way to go about this. is there an intermediate version i need to upgrade to before i can move to 3.4.0 ?

Nick Pellow Atlassian Team May 13, 2014

Theoretically the upgrade should just work from 1.6.x to 3.4.3 . (NB: 3.4.3 is the latest version released).

Be sure to take a full backup before commencing, so you can roll back at anytime.

You could even do a test upgrade from the backup.zip on a non-production server to see that everything works fine for you.

Depending on the number of repositories you have and the repository types and the size of the repsitories you have, some upgrade tasks may take a little while to run. The instance should still be usable while they do however.

Please report back how you go.

Cheers,

Nick Pellow

thanks got this to work. When i ran the jsvn command i opted to not store the password and that seems to have resolved the issue

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

136 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you