Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

FishEye GUI does not work

Hi all,

This is my config.xml but the GUI won't start. Logs don't show the error or maybe I am not looking in the right place. Can someone please assist me with that?

[CODE]

<?xml version="1.0" encoding="UTF-8"?>
<config control-bind="127.0.0.1:8066" version="1.0" admin-hash="[data removed]" timezone="America/New_York">
<!-- see example-config.xml and config.xsd for more documentation -->

<license SID="[data removed]</fisheye><crucible>[data removed]</crucible></license>
<web-server context="fisheye" site-url="https://fisheye-myinstallation.com/">
<ssl bind=":6443" keystore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" keystore-password="[data removed]" truststore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" truststore-password="[data removed]"><excludeProtocols><protocol>SSLv3</protocol></excludeProtocols></ssl>
</web-server>
<security allow-anon="true" allow-cru-anon="true">
<built-in>
<signup enabled="true"/>
</built-in>
<admins><system-admins/></admins><avatar><disabled/></avatar></security>
<repository-defaults>
<linker/>
<allow/>
<tarball enabled="false" maxFileCount="0"/>
<security allow-anon="true"/>
<text-indexer enabled="true"/><watches enabled="true"/><commit-message-syntax syntax="plain"/><changeset-discussions enabled="true"/><show-checkout-url>true</show-checkout-url></repository-defaults>
<check-for-updates/><snippet/></config>


[/CODE]

Thanks

1 answer

0 votes

Hi,

 

From the extract of the config.xml it looks like the http/https configuration might be off in your file:

<web-server context="fisheye" site-url="https://fisheye-myinstallation.com/">
<ssl bind=":6443" keystore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" keystore-password="[data removed]" truststore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" truststore-password="[data removed]">
<excludeProtocols><protocol>SSLv3</protocol></excludeProtocols>
</ssl>
</web-server>

 

 

Also from the config.xml seems the instance is brand new, with no configuration or repositories made yet.

If this is true we should start fresh  and apply the ssl configuration later on.

  • Try to modify that section to:
<web-server>
        <http bind=":8060"/>
    </web-server>

so to reset the configuration to the default HTTP and see if this makes Fisheye able to start

  • If that works means that Fisheye is healthy and that the ssl configuration was the culprit
  • After that you can try adding the ssl block back:
<web-server>
  <http bind=":8060"/>
<ssl bind=":6443" keystore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" keystore-password="[data removed]" truststore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" truststore-password="[data removed]">
  <excludeProtocols><protocol>SSLv3</protocol></excludeProtocols>
</ssl>
</web-server>

and check if you can access to <fisheye_ip>:6443

  • If also this works you can re-add the context:
    <web-server context="fisheye" site-url="https://fisheye-myinstallation.com/fisheye">
    <http bind=":8060"/>
    <ssl bind=":6443" keystore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" keystore-password="[data removed]" truststore="/usr/java/jdk1.8.0_152/jre/lib/security/keystore.kst" truststore-password="[data removed]">
    <excludeProtocols><protocol>SSLv3</protocol></excludeProtocols>
    </ssl>
    </web-server>

     

Another alternative is to move the SSL configuration on a reverse proxy (like Apache or NGINX) and configure a reverse proxy in Fisheye. If you are interested in that you can get more information at Securing your Atlassian applications with Apache using SSL

 

Hope this helps

Daniele

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

ThinkTilt is joining the Atlassian Family!

This morning, Atlassian announced the acquisition of ThinkTilt , the maker of ProForma, a no-code/low code form builder with 700+ customers worldwide. ThinkTilt helps IT empower any team in their or...

467 views 20 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you