Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Failed to setup git executable

when I try to setup git executable to add git repo

It always give me failure info:!Invalid git executable: Unable to get git version

I check that the git executable exactly exists and can be executed by the user used to run crucible&fisheye

I check that the owner of git executable is the user used to run crucible&fisheye

SOS,give me some help!

Great thanks!

3 answers

1 accepted

0 votes
Answer accepted

I have solved this problem by setting up swap area.

You'll need to configure the path to the Git executable:

I provided the path like this:/home/crucible/bin/git

/home/crucible is the home directory of user crucible while I use to run crucible/fisheye

but the same failure

This solved my problem. My error was: Caused by: Cannot run program "git": CreateProcess error=2, The system cannot find the file specified

I've got the same error, but there are no error messages in logs. Any ideas?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

⏰ Day in the life of a Jira Admin!

Hello Community! We thoroughly enjoyed this just-for-fun conversation in the Jira Admin Group about what it's like to be a Jira Admin. For #JiraJuly, our talented designers created these graphics t...

932 views 2 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you