Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,366,955
Community Members
 
Community Events
168
Community Groups

Email notifications are not working

Whenever an action is taken in Crucible that should generate an email, the emails are not being received.

The Fisheye / Crucible mail server is configured -- our email server is setup to require a login and a valid user name and password are set. It appears that all works OK when 'Send test email' is attempted.

Looking at the log file in C: FISHEYE_Home var log I see the following error messages when notification emails should be sent from Crucible:

INFO | jvm 2 | 2012/12/21 14:12:59 | 2012-12-21 14:12:59,829 ERROR - problem sending email

INFO | jvm 2 | 2012/12/21 14:12:59 | com.sun.mail.smtp.SMTPSendFailedException: 550 5.7.1 Client does not have permissions to send as this sender

We are running Small Business Server 2011 and Exchange 2010. I believe I have relaying enabled correctly for the internal IP addresses. Also, we have JIRA, Confluence, and Bamboo running at our site and have no issues with notification emails being sent.

Thanks in advance for any help you can provide.

Gary Cane

2 answers

1 accepted

0 votes
Answer accepted

Make sure to check the radio button for send emails from server address or user address on the mail server setup page . . . in my case it was set to user address and the user address was not a fully qualified email address. The server then treated the email as a relay request from an untrusted source.

where to enable that radio button. I don't see on my confluence page.

I know it's very old post however thought of seeking help.

@Pareshkumar Gandhi, did you ever find this as i am not seeing the radio in version 7.1.7

0 votes
Naren Rising Star Dec 23, 2012

Hi Gary,

Please refer this KB available for the error.

com.sun.mail.smtp.SMTPSendFailedException: 550 5.7.1

Hope this helps!

Turned out this was a setup issue. I had missed the radio button for Send emails from 'the server address or the user address'. This was set to the user address (which did not have a fully qualified name). When I changed it to server address the emails started working.

Thanks for your help . . .

Gary

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events