This question is in reference to Atlassian Documentation: Installing Crucible on Linux and Mac
When trying to start Crucible I get the following message:
"FishEye/Crucible requires Java 1.8 or greater. Your version is 1.7.0_95."
But 1.7 is the lastest OpenJDK version, which is explicitly supported. How can I skip this invalid error message?
In that case the information on the website it incorrect:
"The version of Java should be 1.8.x (or 1.7.x for OpenJDK)."
Can someone confirm?
Yup, that's a definite error.
Atlassian are good at updating the "supported platforms" pages, and I always rely on them. https://confluence.atlassian.com/crucible/supported-platforms-298977375.html states 1.8 is the only supported version. Obviously, someone didn't get around to updating the duplicated information...
You're correct, although the Supported Platforms page states that support to Java 7 was removed on FishEye/Crucible 3.9, the install docs were not updated accordingly. I've updated the install docs both for 3.9 and 3.10 to reflect this change.
Thanks for noticing and reporting this.
Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...
Connect with like-minded Atlassian users at free events near you!Find a group
Connect with like-minded Atlassian users at free events near you!
Unfortunately there are no AUG chapters near you at the moment.Start an AUG
You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs
We're bringing product updates and pro tips on teamwork to ten cities around the world.Save your spot