Crucible fails to start git repository with message: Unable to get git version.

I've tried adding the first Git repository to a brand-new installation of Crucible, and I'm getting the following message when trying to start it:

Failed to start repository rdr-evaluation-framework: Problem loading repository 'rdr-evaluation-framework' - Unable to get git version.
You are running release CR2.7.6 FE2.7.6 (20111107234450 2011-11-08), please report your release number when reporting bugs.

Any ideas what it could be due to? Git is available in /usr/bin/git and gives the following output when run as the user who started the Crucible process:

---> sitebuild@SERVER (0.07)$ git --version
git version

Thanks in advance for any help,


4 answers

1 accepted

1 vote

Please refer to this discussion on our old forums. The best bet seems to be to increase your swap space.

Increasing the memory allocated to the virtual Linux container solved the problem, the repository can be started now. Thanks for the help!

0 vote

Can you look at the FishEye debug log in var/log and get some more detail about what is happening around the execution of the version check? There may be an exception stacktrace which helps to narrow down the cause. It may help to turn on debug level logging to get more information on the command as FishEye is executing it.

That seems like a good tip - it looks like Crucible is running out of memory:

Caused by: com.atlassian.utils.process.ProcessException:
Cannot run program "git": error=12, Cannot allocate memory

It's a little odd, though, because the heap size is set to 1GB, but the system info page is reporting Total Memory 224M, Free 70M, and the Linux VM is reporting about 300M free memory, and that the Java process is taking up 1645M virtual memory. Not sure how to reconcile those numbers?

This is what I got in the Fisheye log:

Caused by: Cannot run program "git": CreateProcess error=2, The system cannot find the file specified

I installed Fisheye together with JIRA on a Windows box, running under Local System Account. My GIT repository is on a Linux box.

So what does log message mean? Who wants to run program "git" on where? I have git installed on the Fisheye server and added it to the system path, can run git from a command prompt.



0 vote


FishEye executes the git command to interact with git repositories. It is necessary to have git installed and accessible to the FishEye process for FishEye to index a git repository.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

130 views 3 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot