Configure file size display limitation in Fisheye?

After a first index of our SVN repo with a "Maximum Indexable File Size" we've learned that we have sources which exceed that limit. The size of the file was some 190k while "Maximum Indexable File Size" was set to 0.1M

According to the documentation under https://confluence.atlassian.com/display/FISHEYE/Text+file+size+limiting
(By the way, shouldn't it say "From FishEye 2.7" instead of "In FishEye 2.7"?), configuring "Maximum Indexable File Size" to a higher value and running a re-index should make the file available for display.
This is what I did, however, the file still is being marked as "too large".

Am I missing something? Please advise

6 answers

Hi Gustavo,

I have the exact same problem. I tried all steps you described but it didn't solve it.

It's the same file which did not work before at which still does not show a diff (around 152 KB). Before, the default limit has been 100 KB. Now I changed it to 5 MB per default and for this specific repository as well. Re-indexing did finish and I also tried your suggestion to stop Fisheye, delete the folder and start Fisheye again. After succeeding re-indexing, the diff is still not shown.

It still says:

thefile.cpp is too large to show a diff.
To see the diff between revisions 15198 and 15590 of thefile.cpp download them and use a diff tool. For more information about text file size limits and how to modify them see the documentation.

Please also notice that in Fisheye itself, e.g. when clicking on the revision, the diff is shown!

It's just not shown in the review.

Can you please help us since this is really a severe problem if we cannot diff files above 100 KB in a review.

Best regards

Btw: My current version is: Atlassian FishEye analysis with Crucible code review. (Version:3.8.0 Build:20150427140019 2015-04-27)

I'm having the exact same issue and it's driving the team nuts. We need to be able to easily code review our large files. I've set the limit to 5MB and re-indexed and still we can't review them.

We are having the exact same problem.  After re-index and started FishEye, still receive the message stated the files are too large. 

I have tested this in version 4.0.2 and the same problem is occurring, no matter how high i set the file size limit.

Has anyone figured out how to work around this issue?  We're seeing the same behavior on v4.0.4.  After resetting the maximum indexable file size for a single repo and reindexing we're still seeing the too large to show a diff warning in the review even though the file size is well below the maximum. However, LOC now works in the file view.  I really don't want to have to reindex again, though it's being done offline on a clone host, since it takes almost 3 weeks to complete on this one repo.

Forgot to add that selecting FishEye > View File Diff from within the review is works fine even though the review still itself shows that the file is too large to show a diff.

Hi Steffen,

Thanks for noticing the misspelling, I'm going to check this in order to apply the change to the documents.

Please allow me to do some checkings form what you described:

  1. Can you please confirm the file still shown as too large is the same file with 190k you were trying to see before, and also to what value you set this option?
  2. When prompted for a re-index did you allow it to re-index your repository, and did it finish re-indexing?
  3. In case the re-index completed and it's still not working please give a try to a manual re-index of this repository:
    1. Stop FishEye.
    2. Delete the directory $FISHEYE_INST/var/cache/<repository_name> (this will delete the indexes of this repository).
    3. Start FishEye (this will automatically trigger a re-index for this repository).

Regards,

Gustavo Refosco

In case someone else lands on this page trying to figure out how to set the maximum indexable file size, the setting is buried under Admin > Repository Settings > Defaults > Other Settings

@Aaron Bauman I did finally find that setting and change it but we are still unable to see large files even after a reindex sad  (Also changed it at the project level and refreshed)

I have tested this in version 4.0.2 and the same problem is occurring, no matter how high i set the file size limit.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in Marketplace Apps

You + one app + a desert island...

Hi all! My name is Miles and I work on the Marketplace team. We’re looking for better ways to recommend and suggest apps that are truly crowd favorites, so of course we wanted to poll the Community. ...

126 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you