Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,176
Community Members
 
Community Events
168
Community Groups

Bad version number in .class file

I have no idea what I need to do to fix this issue. Can I please get some guidance.

STATUS | wrapper | 2014/04/28 10:08:39 | Launching a JVM...

INFO | jvm 1 | 2014/04/28 10:08:39 | java version "1.5.0_22"

INFO | jvm 1 | 2014/04/28 10:08:39 | Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_22-b03)

INFO | jvm 1 | 2014/04/28 10:08:39 | Java HotSpot(TM) Server VM (build 1.5.0_22-b03, mixed mode)

INFO | jvm 1 | 2014/04/28 10:08:39 | JDK 1.5 detected, registering Java Service Wrapper MBean

INFO | jvm 1 | 2014/04/28 10:08:39 | WrapperStartStopApp: Unable to locate the class com.cenqua.fisheye.FishEyeCtl: java.lang.UnsupportedClassVersionError: Bad version number in .class file

INFO | jvm 1 | 2014/04/28 10:08:39 |

INFO | jvm 1 | 2014/04/28 10:08:39 | WrapperStartStopApp Usage:

INFO | jvm 1 | 2014/04/28 10:08:39 | java org.tanukisoftware.wrapper.WrapperStartStopApp {start_class} {start_arg_count} [start_arguments] {stop_class} {stop_wait} {stop_arg_count} [stop_arguments]

1 answer

1 accepted

0 votes
Answer accepted

What version of Fisheye are you trying to run? I suspect you need to upgrade your Java to at least 1.6 and probably 1.7...

Well I went to 1.5 because the error logs were screaming about the version not being JDK 1.5. I will try running on 1.7 and see if anything changes.

I am running 3.4.0. The reason I tried using java 1.5 is because I get this error in the fisheye log when using jdk 1.8:

ERROR [FelixDispatchQueue ] com.atlassian.plugin.osgi.container.felix.FelixOsgiContainerManager FelixOsgiContainerManager$BundleRegistration-frameworkEvent - Framework error in bundle org.springframework.osgi.extender

org.osgi.framework.BundleException: Activator start error in bundle org.springframework.osgi.extender [7].

at org.apache.felix.framework.Felix.activateBundle(Felix.java:1864)

at org.apache.felix.framework.Felix.startBundle(Felix.java:1734)

at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)

at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

at java.lang.Thread.run(Thread.java:745)

Caused by: java.lang.IllegalStateException: Cannot create ConcurrentHashMap - neither JDK 1.5 nor backport-concurrent available on the classpath

I have changed back to 1.8 but now I am running both into this issue, but also when I try to view the web browser page for fisheye, I get:

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'com.cenqua.fisheye.web.admin.actions.setup.WelcomeAction':

The page never loads

I'm vaguely curious as to why you thought downgrading from one non-compatible version of Java to another non-supported version would help, but hey.

Please, run it on 1.7 (or 1.6 if you must). Those are the only two supported (although Atlassian are working on 1.8)

Fisheye 3.4.0 requires JRE/JDK 1.7 or 1.8, see https://confluence.atlassian.com/display/FISHEYE/Supported+platforms
It won't run on Java 1.5 because it is compiled for Java 1.6+ and it won't run on Java 1.8 yet.

Kind regards,

That turned out to be the main issue. I am running into another problem now, but I will research that before asking questions on it. Wish I saw the compatibility page prior to debugging the issue myself. The only reason I tried 1.5 was due to that error message and not finding any support on the exact text.

Thanks guys

Ah, that's good. I think we had to eliminate that as the problem, even if it wasn't the whole issue!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events