Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Application links over https

Hello!

 

The application links from Crowd to Confluence, JIRA, Bamboo, or FishEye/Crucible are working, but none from these applications to Crowd.

Recently I tried in Confluence to delete and recreate the invalid application link. Deletion worked, it's recreation failed in some endless loop. After removin the form to input the URL the Web browser showed something like "Consumer cannot be automaticall configured because remote consumer info not found."

Since the servers are in AWS (Amazon Web Services) not all ports can be used for communication. Are there any special requirements?

The versions of the Atlassian´products are up-to-date, except Crowd which is 3.1.2.

 

--

 

Greetings

   Pete

2 answers

0 votes
Rodrigo M Atlassian Team Jul 24, 2018

Hello Peter!

The first aspect I would like to clarify is that we don't have application links in Crowd. By application link, I understand you are trying to add an application in Crowd according to the Adding an Application documentation.

As this question was raised in the Fisheye/Crucible product, let's focus the integration of this product with Crowd. Please, if you haven't, follow our Connecting to Crowd documentation in order to have all the detailed instructions to integrate bot applications.

There aren't any special requirements if the hosts reside in AWS. You just need to make sure they are able to communicate with each other.

Some questions to be answered:

* Are you accessing both applications through HTTPS?
* Are the base URLs correctly set in both the instances?
* Are they reachable from the each of their servers via the configured base URL?
* Are you using the same URL while entering the link for the application?

One thing that should be noticed is that crowd URL by default is set to http://localhost:8095/crowd/.

You can also check the Fisheye logs while trying to add Crowd User Management to have a better idea of the error being thrown in the logs. The log files are located in <FISHEYE_INST>/var/log/atlassian-fisheye-yyyy-mm-dd

Regards,
Rodrigo

Hello Rodrigo!

Holidays and some employee who could not get updates for our licenses in weeks kept me from working on this problem. Sorry for keeping you waiting!

The licenses for FishEye and Crucible are OK now. I simply wrote them into config.xml since a regular login is not possible (the workaround with the admin hash works and I am logged in as admin).

The documentation at https://confluence.atlassian.com/fisheye/connecting-to-crowd-813695565.html is not correct anymore, the "User Directories" are now found in "User Setting," see attached screenshot.FishEye_Crucible User Directories in User Settings.pngThis also shows that some "synchronisation" had happened shortly before, which failed. There is already a hyper-link "Directory Configuration Summary" under "Additional Configuration & Troubleshooting." Choosing that reveals:

Directory ID: 2
Name: Crowd Directory
Active: true
Type: CROWD
Created date: 2016-03-24 00:00:00.0
Updated date: 2018-08-23 11:08:54.73
Allowed operations: [UPDATE_USER_ATTRIBUTE, UPDATE_GROUP_ATTRIBUTE]
Implementation class: com.atlassian.crowd.directory.RemoteCrowdDirectory
Encryption type: null
Attributes:
"application.name": "fisheye"
"application.password": ********
"com.atlassian.crowd.directory.sync.issynchronising": "false"
"com.atlassian.crowd.directory.sync.lastdurationms": "420"
"com.atlassian.crowd.directory.sync.laststartsynctime": "1535015334310"
"crowd.server.url": "https://crowd.webmiles.biz"
"crowd.sync.incremental.enabled": "true"
"directory.cache.synchronise.interval": "3600"
"useNestedGroups": "false"
"user_encryption_method": "atlassian-security"

Here the application.name is simply "fisheye" which in Crowd "fisheye/crowd" was configured again. Correcting the issue in Crowd (only "fisheye") fixed the issue for Crowd. I could pass the "Authentication test."

On the side of FishEye/Crucible I get the following as result of a test:FishEye_Crucible tests connection to Crowd.pngThat looks already quite fine… Here is the configuration of the application link:Crowd application in FishEye_Crucible.pngNext I'll try to start FishEye/Crusible with regular config.xml file and see whether I can log in.

 

--

Greetings

   Pete

BTW, the correct URL to access as admin via admin.do FishEye/Crucible on the remote server (at least in AWS) is simply: https://<IP address or name>/admin/login-default.do.

 

--

Pete

Logging in now works as expected again.

 

Thank you, Rodrigo!

--

Pete

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

⚡️NEW Group for Confluence Cloud Admins

Calling all Confluence Cloud Admins!  We created a new Community Group to support your unique needs as Confluence admins. This is a group where you can ask questions, access resou...

114 views 2 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you