Access Fish Eye & setup URL

Hello I recently configured my jira to a url (proxy/IIS): https://community.atlassian.com/t5/Jira-Software-questions/Configure-URL-of-JIRA-Server/qaq-p/656724

Since then, the commits within jira say: "You don't have access to view all related commits. Please contact your administrator."

Also, when i try to access my fish eye, my credentials do not work anymore. I tried to reset the admin password but i still cant get in.

Need help ASAP! 

 

1 answer

This widget could not be displayed.

Hi Christos,

When you tried the steps to reset the admin password, after you updated the config.xml did you restart Fisheye in order for these changes to take effect?   If you did not restart Fisheye yet, then that could explain why this is not working yet.   However if you did this, then you should be able to click the Administration link in the footer in order to enter this "admin" password.

If you have done those steps and this still is not working, then we would want to gather your config.xml in order better understand your configuration.   

Please try these steps once more, if this is still not working please let me know by replying here, and in turn I can create a support request on your behalf where we can then gather this file from your privately.

Regards,
Andy

Hi Andy -

Thanks for the reply. Using the Administration link below i was able to login. However, I still can't login with my regular username and password.

Also, as I said to the post I changed my jira url and now I do not have access to the svn commits within jira.

I supposed the next step is to update the Configuration Application Links within jira, and update the proxy for fisheye, but I'm confused to why i dont have access to fisheye anymore....

Just to summarize the issues I'm having:

- Can't login to fish eye with my regular credentials (using crawd for authentication - same creds with jira)

- Want to change my fisheye url with iis proxy

- Commits within jira are not visible anymore

Any ideas?

I think I messed up fisheye and now it is not loading at all.

I have update the settings here: https://confluence.atlassian.com/fisheye/configuring-the-fisheye-web-server-298976936.html

with the new url and now the site is not comming up.

How can I revert the values from the fisheye server?

 

I also saw that probably my  regular credentials to fisheye were not working because in the config.xml it was pointing to the old jira url

Btw, I thought this was support? I'm trying to ask a question to the support (which I'm paying) and i always get direct to the community... confused.

Sorry for the multiple replies.... I was able to fix the issue of the fisheye loading by recovering the config.xml - i'm back to these issues:

Just to summarize the issues I'm having:

- Can't login to fish eye with my regular credentials (using crawd for authentication - same creds with jira)

- Want to change my fisheye url with iis proxy

- Commits within jira are not visible anymore

Hi Christos,
There was a change made back in July of this year in regards to how Atlassian provides support for Starter licenses.   https://www.atlassian.com/blog?p=37521 explains this change in more detail.  Moving forward, support for starter licenses is provided here, directly in the community site.   Support for other commercial licenses is still provided by Atlassian Support.   When you first create a support ticket on https://support.atlassian.com you have to enter a SEN number (support entitlement number).  This form is then directing your request to one location or the other depending on the SEN you enter here.

Login issue:
For the login issue here with Fisheye, I understand you are wanting to use Crowd to manage the login credentials for Fisheye.  Was this setup and working previously already?  Or has this just stopped working since the introduction of the reverse proxy?  Basically, I would want to take a step back to understand those parts first and then use Integrating Crowd with Atlassian FishEye as a guide to make sure that you can use Crowd for this.

This guide will provide the steps you need to take in both applications in order to configure this.

Proxy setup:
As for setting up Fisheye to work with an IIS reverse proxy, we have another guide on the steps needed to complete this.   Please see Proxying Atlassian server applications with Microsoft Internet Information Services (IIS)

Application link update:
Once Fisheye is setup behind this proxy, you will likely need to edit the application link settings in both Jira and Fishey, in order to make this link work.  There are two different approaches you can use for this.  One is to update the URLs in the application link to reflect the updated public URLs.   If this isn't working then we have an alternative method you can use to bypass the proxy in order to create applications links.

Please try to follow these steps and let me know if you run into any problems trying to follow these guides.

Regards,
Andy

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

70 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you