Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,455,912
Community Members
 
Community Events
176
Community Groups

getting "Cannot determine required plugins, cannot resolve bundle error"

To edit pdf file, i am in need of itextpdf jar. I have added the itextpdf in pom.xml file when i build plugin its seem to error. the following

SDK version : 6.3.10

itextpdf  version : 5.5.3

java version: 8.0

 

<!-- https://mvnrepository.com/artifact/com.itextpdf/itextpdf -->
<dependency>
<groupId>com.itextpdf</groupId>
<artifactId>itextpdf</artifactId>
<version>5.5.3</version>
<scope>provided</scope>
</dependency>

 

cause Error

ERROR - 09:54:06,519 - com.atlassian.plugin.osgi.factory.OsgiPluginInstalledHelper - [localhost-startStop-1]
- Cannot determine required plugins, cannot resolve bundle 'com.web.pdf.gen'

 

2 answers

1 accepted

5 votes
Answer accepted

It's Fixed by adding, in my pom.xml

<Import-Package>*;version="0";resolution:=optional</Import-Package>

Great Job. Working fine.

Faced with the same problem, only when connecting to any other jar file. Please show your corrected pom.xml. Thank you in advance)

Love you, bro. It works for me, too.

This thing solved whole day of researching this issue. Happened when adding an external jar and using its methods

Спасибо!

0 votes

Hi,

Why do you set scope provided? I think you need scope compile.

Hi Aleksandr,

thanks for your reply. i tired all of this (compile, provided, runtime),

1) .i have clean and run plugin,

2).my local repository has itextpdf.jar ,

3).updated version of SDK & Java.

But, Same error! i am stuck in it. My plugin not enabled. Can you help?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events