Jira jwt installed but sharedSecret is not returned

Hello,

I created an atlassian connect addon in my atlassian DEV environement.

I added an installed callback to the addon descriptor, the callback is used to get and save the JSON payload (security context).

I installed the addon and everything is working fine.

the only issue is that when I checked the JSON payload returned by the atlassian product (jira) I found that the 'sharedSecret' is missing from the JSON object.

The JSON payload is looks like this

{"key":"key","clientKey":"xxxxxxxx","publicKey":"xxxxxxxxx","baseUrl":"https://xxx.atlassian.net","productType":"jira","description":"xxx ","eventType":"enabled"}

 

It's normal? Or have I forgotten something?

 

Thank you.

1 comment

Hi,

I finally find the cause of the issue described above. On my addon descriptor the installed and enabled callbacks are the same so when I install the addon both callbacks are called and the payload of the last callback (enabled) is saved. Knowing that the sharedSecret is not returned on the enabled callback this is why I did find it on the JSON object.

 

Thx

Comment

Log in or Sign up to comment
Community showcase
Posted Tuesday in United States

Topic Tuesday: What's your favorite topic?

Good morning All, Our goal is to get you into the habit of while enjoying your favorite morning drink you are checking the NOVA "space" for topics and comments. Your input is really needed and...

59 views 4 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you